Shared folder: no "Write" access for Guest

NethServer Version: v7RC1
Module: Samba AD \ Shared folders \ Guest access

Hello everybody,

I have the following situation:

  • NS 7RC1 as DC/AD
  • Placed in LAN, one NIC
  • DHCP: Enabled
  • Shared folder created with:
    • “Allow read permission to everyone”: Enabled
    • “Guest access”: Read and write
    • No ACL
  • Win 7 Pro WS (no added to domain)
  • Win 10 Pro WS (no added to domain)

I can see and can access the folder, but I cannot write inside it: Destination Folder Access Denied; You need permission to perform this action

I have tried to map the shared folder, using different credentials: no chance (after I clicked on OK, another pop-up for credentials for a few times, till a new message is showing).

What did I do wrong?

TIA,
Gabriel

Hi @GG_jr
try to open a DOS prompt and type:

net use

if you find the active connections, disconnect them with

net use / d \\servername\share

reconnect with

net use \\servername\share /user:_username_ _password_

The windows logon user/password coincide with those created in nethserver?

Hi @enzoturri

Thank you for your help!

Look what I have got:

(On NS, I have only two users: administrator@abt.ro and gabriel.gheorghiu@abt.ro)

the problem is “Multiple connection to server…”.
Windows find a connection active with a different user.
Try to open a dos shell with “run as administrator”.

net use /d \\ 192.168.1.2\gabriel_georghiu

otherwise
logoff Windows
logon
open dos prompt
execute

net use \\servername\share /user:username password

I did it again, this time I have rebooted my laptop in win7.

EDIT:

Another one.

sorry,
you write
net use \\server\share /user:username password
and not
net use \\server\share /user:_username_ _password_

it works?

I don’t know if is relevant: the shared folder properties are changed only for “Allow read permission to everyone” (Enabled or Disabled).
I don’t see anything for Guest.
It’s OK?

the underscore should not be put.
The result is always “completed successfully” if username / password is correct sign in as a user, if user and password are incorrect sign in as a guest.

Your user is part of the group owner? if it is not, you have read-only rights.
To try deactivate guest access, activate write permissions of the owning group and put the user in this group. deactivate read rights to other users.

In this way you need to enter the correct user or I will return an error.
Once solved, only activate the guest in writing

in version 6.8 there was “reset permission” under “ACL”

I try the virtual machine and let you know. The problem is that I have internet at home that is going to -1.2 1 MBit :rage: :tired_face:

Sorry to bother you, but I don’t understand something:

Why a"Guest" must be part of a “group owner”?
As a “guest” I can access any shared folder in the network if the properties of the folder permit the full access to Everyone. At least on Windows.

EDIT:

If I remember well, Davide said that a user who is not domain member, can access with full permissions a shared folder, as a guest, logged to that folder with any username and any password (wrong username and password). In Help pop-up, I think is written the same. Let’s see:

Anyway, I will try to do what you said.

you’re right, (the only condition is that your user in windows is not equal to that of nethserver otherwise you’re not a guest but authenticated user).

Something is not working.
to make it all work probably just run linux shell:

cd /var/lib/nethserver/ibay/
chmod 777 gabriel_gheorgiu

but it means that it does not work properly from web interface
I try and update you

2 Likes

I suspected that this could be the problem but I don’t know very well how Linux works.

OK!
That’s was!

Now it works! I can create file and folders an I can delete.

Please, can you report as a bug in github? I don’t know how!

PS
Give me couple of minutes to restart everything to see if it works again.
I will report back after that.

1 Like

Last question: your user in windows is equal to that of nethserver?

In Win 7, yes.
I will reboot in Win 10 where the user is different and I will report back.

=================
It works from Win 7 (I will check also from Win 10, but should be fine).

I changed the guest properties from Read and write to None, from GUI.
The properties for the shared folder have changed.

I have changed back to Read and write, but nothing till I have runed the command from CLI.

Please, give me 10 minutes to reboot in Win 10.

It works very well in Win 10, too.

I logged in to the shared folder with “blablabla” as username and password and it was OK!

The conclusion: It’s a BUG in GUI.

Now I can go to the next test/step: adding a computer in the domain and check the RSAT.
But tomorrow or from Monday!

Thank you again!

3 Likes

I replicated the problem in 6.8.

if the windows user coincides with the nethserver you’re not a guest.

Probably if you restore the folder rights. Windows 10 (with user blablabla not present in nethserver) works

I don’t think so because when is not worked, not worked on both OS, Win7 and 10, in the same maneer.
The user “blablabla” does not exist on NS.
When I want to connect to the shared folder “gabriel_gheorghiu”, a pop-up windows ask me to introduce the credentials. That user and password, “blablabla”, does not exist anywhere!

In Win 10, if I log in pop-up window with abt\gabriel.gheorghiu (gabriel.gheorghiu@abt is created on NS), I can full access “gabriel_gheorghiu” shared folder, but also is showed the folder "gabriel.gheorghiu@abt.ro", with full access rights.
If I log in with “blablabla”, I can see only “gabriel_gheorghiu” folder.
All that are correct.

Is late now, but tomorrow I will check also in Win 7. Should be the same.