Service errors on NS from Proxmox: Example NFS

Good morning Stephane

I kindly ask you for help on one of the modules you prepared: NFS

Currently, I get an error on any client, while linking the shares via fstab is still no problem.

showmount -e
clnt_create: RPC: Program not registered is my NS with NFS enabled. NS is running for ages and current NFS connections on clients are accessible. My problem is more that I want to set up a new machine and it is easier to check the server than mount / umount shares.

Thank you, best regards and take care to stay healthy

1 Like

do not understand, you cannot create your share from the UI ?

No, the share is available, I can create and alter shares, but I do not see them on the client - suddenly they disapeared. Usually I mount them via /etc/fstab, but that, as well as showmount -e does not work anymore.

it is on all clients or only one specific client ?

It is somehow strange:

a) showmount -a does not work on any client (4 of 4 tested, is the NS“

b) sudo mount /mount/point does not work on any client, even if client is rebooted

c) share already connected on clients are accessible (r/w tested on 2 of 4 clients)

d) sudo umount /connected/share && sudo mount /mount/point does not work, tested on 1 of 4 clients

e) tried some reconfigurations of NFS shares and manual start / stop of nfs service from NS webfrontend - same behavior

f) tried reboot of NS - same behavior

will try again today evening …

check the services are up

'nfs-lock' => 'restart', 
'nfs' => 'restart',
'rpcbind' => 'restart' );

check the permission of files/folders

„Found it“: The dedicated SDD for ZIL, LOG and Cache on the parent VM host (Proxmox) died. This resulted in a major loss of performance on the hosted NS. It appeared busy to its clients while major services were more or less unaffected or at least effects were not noticed. After removing the SDD from the respective ZFS pool and a total reboot all systems (host / guests) everything came back to work as usually.

1 Like

Would you mind to find a nice title and open the tread to the public, it could help someone else

Yes, of course, just a question: is there any technical method to “open to the public” or do I need to copy paste :slight_smile:

look at the tool on left, you have a make the topic public

Screenshot (7)

of course I agree :slight_smile:

1 Like