Server does not open in browser


(Serg) #1

NethServer Version: 7.5
Module: none
Hello friends,
I’m a fairly new user of Nethserver :slight_smile:
I installed NethServer, I can ping local and external addresses (ping 8.8.8.8 or ping google.com) from the server, yum update succesfull, the server itself from the local network is pinged, but it does not open in the browser at link: https://_Server_IP:980
Help me, please


(Rob Bosch) #2

Just to doublecheck your ip address is correct, can you open a terminal on the server and post the outcome of ipconfig?
Is your server configured as gateway? (using a RED and GREEN interface? Or only with a GREEN interface?


(Serg) #3

Hi.
IP correct, but I have only one interface :frowning:
The server is deployed under a VM (Proxmox). What is easier? Reinstall with two interfaces or add another interface into the current server? If I add another interface how to configure them? GREEN and RED


(Stéphane de Labrusse) #4

You should explain us a bit how your network works(ip addresses, netmask), if you used a bridge for the network of the vm proxmox or a NAT (virtual network)

https://pve.proxmox.com/wiki/Network_Configuration

The bridge is the better way, else each needed port must be routed to the VM


(Saito Benkei) #5

Are you trying to log in with Firefox?

Try this:


(Serg) #6

First trouble solved:
The reason was that I installed on a host with one network card. The installer apparently decided that he is the only not GREEN one. I don`t know…
At now trouble number 2 :slight_smile:
I installed NethServer on a host with two network interfaces, the server is available on the local network (both iface), pings out (8.8.8.8 / URL) but cannot download anything: applications (via the web interface) or yum update via CLI.
wtf …


(Ralf Jeckel) #7

What failure do you get, when you do yum update ?


(Serg) #8


(Ralf Jeckel) #9

Try the following, if not already done:

yum clean all
rm -rf /var/cache/yum/*

if that doesn’t help, please try to rebuild the yum database:

rm -f /var/lib/rpm/__db*
rpm --rebuilddb
yum clean all

(Rob Bosch) #10

If you can ping an IP but not a hostname, you should have a look at your DNS settings


(Serg) #11

Bingo !
flatspin Thanx, this this advice helped

yum clean all
rm -rf /var/cache/yum/*

2 robb
I could do both ping by address (8.8.8.8) and by URL (google.com and e.t.c.)


(Ralf Jeckel) #12

You’re welcome. If there are no more issues, please mark the topic as solved.


(Saito Benkei) #13