Samba lost all passwords & phpmyadmin admin not work


#1

Hi,
Tonight my server with nethserver 6.5 had some problem. Yesterday everything worked.
This morning the samba server not authenticated the user. To resolve the problem i had to reassign the (old) password to every(!) user and restart the smb server. Restarting smb server without reassign password not worked.
What could have happened ?

Another problem was phpmyadmin. The admin access that yesterday worked fine, today doesn’t work ! I checked the password… and the password was fine… i have re-installed nethserver-phpmyadmin package but admin access keep not working.
The only way to have phpmyadmin working was enable multi-user access.
Phpmyadmin config:
access = private
adminaccess = enable
multiacces = enable

What i have to do to get back phpmyadmin admin access working ?


(Stéphane de Labrusse) #2

You have a problem with ldap…either the service has stopped or you have had your ldap base corrupted


#3

The samba user and the group was correct. Only the password seemed lost.

But for phpmyadmin admin access what i have to do ?


(Filippo Carletti) #4

phpadmin is a php app. I hope you’ll find errors in /var/log/httpd/error_log.


(Stéphane de Labrusse) #5

set again a password to the admin user


#6

Do you mean the root server user ?

The user “admin” of mysql server has a different password than a “root” user of the entire server.
Until yesterday i opened https://myserver/phpmyadmin and use the credential: User: “admin” , Password: “admin MYSQL USER password”. And all worked fine. Now it won’t work :frowning:

The “root” user isn’t related to the “admin” user of mysql/phpmyadmin… isn’t it ?


(Stéphane de Labrusse) #7

Go to the server-manager and set a new password to the user ‘admin’


(Stéphane de Labrusse) #8

In fact for old compatibility reasons often i password protect a web application by a user called ‘admin’ which is less used now in neth.

Indeed with ns6.6 you use the root user to access to the server-manager now.

What i don’t understand is the password you used to access the phpmyadmin module…it should be related to the admin user you used in ns6.5 to log in the server-manager.

Like philipo noticed it you should look to the httpd error log but i guess i know the reason.

Try to solve first your problem of password with the user admin…can you log in with this user in the server-manager ?


#9

Yes i can log in the server manager using User: root, Password: root password
The password of root user wasn’t lost, otherwise i couldn’t change other user samba password.
I use nethserver 6.5

P.s. The demo on docker is broken. Login not work for user root with passoword: 1234 or Nethesis


(Stéphane de Labrusse) #10

and with the user ‘admin’ can you log in the server-manager


#11

I never created a user “admin”. Is the user “admin” created during the setup of nethserver ?
I never used “admin” as user to login in the server-manager dashboard… i use always root user for the server-manager.


(Stéphane de Labrusse) #12

but you used it before you have had an issue with your servers :slight_smile:


#13

“admin” is a user that only exist on mysql server that can manage some databases… root user on mysql server can manage all databases.
The password of “admin” user on mysql is the same there was before the crash. I have checked it after the issue to the server.
I will check a list of the nethserver user :wink:


(Filippo Carletti) #14

It works for me. User=root Password=Nethesis,1234 (the default password)


(Michele Bortolotto) #15

@Technet have you installed file server or mail packages? If yes you have an user called admin “users” in the dashboard


#16

The user admin was completely lost.
After a backup i disinstalled and reinstalled the file server package. After that the user “admin” reappeared in the list of the user.
Now everything works.

A question for the developer:
If i have some share forlder and disinstall and reinstall the file server package, it recognizes the presence of the old shared folder or i have to recreate it by the dashboard ?


(Davide Principi) #17

I didn’t check this out, but the shared folder should appear again because:

  • the Accounts DB is not modified on uninstall
  • the directory is not deleted on uninstall

#18

This is the most important thing !
Combined to fact that if Accounts DB is corrupted or deleted and the directory exist the file server doesn’t delete the folder if already exist when from the dashboard the user require to create a directory with the same name. Should work this way… isn’t it ?


(Davide Principi) #19

Yeah, it should work that way, but to be sure an experiment could confirm.


(Stéphane de Labrusse) #20

this should be inspected and understood. It is a huge problem