Samba does not accept a login or password

samba
sharedfolders
activedirectory
v7

(Manonthemoon Ak) #1

Hello,

I have one more problem with NethServer.
Samba does not accept a login or password.
Users in a group.
What could be the reason?


(Stéphane de Labrusse) #2

many reasons… could you check the logs

/var/log/messages
/var/log/secure

also describe your scenario


(Manonthemoon Ak) #3

I have created the centos.com domain (AD).
Create a group in the domain group@centos.com
I have set up user@centos.com
I have added a password for user@centos.com
I added the user to group@centos.com.
I added ACL reading and writing to user@centos.com
Login fields and passwords are displayed. Sign in user@centos.com and password. I also tried centos.com/user and password. Same “user”.
Interestingly, even the ability to enter data is not immediately blocked and powerless.
Honestly, it annoys me.
Logs will be available after the weekend.


#4

domain\user for win machines.

not… domain.tld\user


(Manonthemoon Ak) #5

Thanks.
I tried centos/user :slight_smile: No effect :unamused:


#6

----> \
not ----> /


(Manonthemoon Ak) #7

Yes -> \ not -> /
My distraction now.
I typed \ of course.


(Markus Neuberger) #8

Hello,
just an idea, do you use virtualization? Then you have to setup promiscous mode for samba to work. See http://docs.nethserver.org/en/v7/accounts.html#installing-on-a-virtual-machine


(Manonthemoon Ak) #9

Samba is visible on the network.
It works.
I can not set a password -> I can not log in then.
It works for “guest” (reading, writing). You can turn it on and off


(Markus Neuberger) #10

Can you ping your nethserver AND the NSDC container, named NSDC-YOURNETHSERVERHOSTNAME from your network?
When I set my VMware vswitch to forbid promiscuous mode, I get the same problem you have: Only guest account login possible.


(Manonthemoon Ak) #11

I will try to do it on Monday.
Just remember that this is not a VM :slight_smile: It’s a logical network at school.
Did you fix it somehow?
In addition to this problem everything works.


(Markus Neuberger) #12

Very curious already…

I was asking twice just because I had a similar login problem but with promiscuous mode…:slight_smile:

Yes, as already described, allowing promiscuous mode…

This also may help a lot.


(Manonthemoon Ak) #13

I’m sorry for a long break in the write off.
At that time the system fell. I found an error in the domain.
Solutions were not effective.
I reinstalled, configured. All over again.
It seems ok, but …
Passwords work once, not once. I do not know what it is caused. Sometimes errors credentials.
Sometimes the server is visible in a network environment, and sometimes it has to be manually entered -> \ \name
This may be a problem. I think I’m missing out on patience :confused:


(Markus Neuberger) #14

No problem.

Please test the connection until it doesn’t work and provide the logfile /var/log/messages, maybe we can find the error and solve the problem…


(André Wismer) #15

Hi
Just a gut feeling here: Any chance of an IP conflict somehow?

The described phenomon I experienced with a PC with ann onboard network card. Not a no name!
The network card would light up as expected, sometimes the net would work, but not all servers reachable, most times it wouldn’t work and we’d have other machines dsplaying connectivity problems.

It turned out that card wasn’t reacting correctly to ARP - TCP/IP uses ARP broadcasts to create an IP - Mac-Address Lookup-Table. (arp -a on most tcp/ip enabled machines with a console…) and sometimes used the DHCP servers IP / MAC Addr sometimes it’s own, sometimes other servers.

In the end we isolated that network interface, deactivated that NIC in BIOS, and put in a PCI NIC.
Problem over!

My 2 cents
Andy


(Manonthemoon Ak) #16

My logs /var/log/messages
Logs

I also wonder if it is not a network card fault.


(André Wismer) #17

Hi

I’ve also had the rather unusual constellation where it was the clients bosses new PC acting funny after half a year.
Login OK. Email without attachments were mostly OK. With attachments almost never. Opening files from the server was flakey at best, mostly it would not work. Internet would work, but half the web could not display… Often also DHCP problems. Tried with adding a second NIC (LAN-Card) to replace the onboard one - still the same effects.

In the end, I plugged that PC directly into the switch, a floor lower. Everything worked. Testing another PC in the bosses office the same phenomens, bad connectivity…

We measured the in house wiring, which was by then about 10 years old. The cabel in the wall was screwed, either corrosion oder some other issue. After the electrician repaced the wiring, all worked and I could reactivate the original NIC and remove the PCI one.

A lot of us IT guys consider in wall cabling almost as sancrosanct, we never question connectivity. But sometimes it’s just that! And I’ve also seen electrcians mount LAN wiring into a cabel-channel with broken copper sticking out of the side… (I only let the guy go AFTER he replaced the non working wiring he just mounted…).

It’s not always our logic or the higher lever network stuff. Sometimes you can’t rely on even basic copper - but the error is IN the wall, so you can’t “see” it!

My 2 cents

Andy


(Ralf Jeckel) #18

just 2 things I noticed:

  1. centos.com is a real and existing domain => it’s a logistic company
  2. AFAIK the doamin has to be in upper cases => DOMAIN\user (at least in my installation nothing else worked)

(Manonthemoon Ak) #19

I do not have the centos.com domain anymore. It was only for tests :wink:


(Markus Neuberger) #20

I’ve read through your log and just found some

Error was NT_STATUS_NO_SUCH_USER.

messages.

I agree. If the same user sometimes is found and sometimes doesn’t exist it may really be a network card or cable fault.