SAMBA - DNS - problems?

I have a problem with the Sambafreigageben and name resolutions in the local network.

I’m not sure where the error can be - DNS - SSSD - SAMBA ???

Partly no connection to the release is possible.

\\jagerbox\ablage - registration not possible
\\\ablage - registration possible

Approach of the virtual server with name resolution possible.

Furthermore, I have problems that the directories are not writable, although the releases are set accordingly and has worked several days.

There are no entries in the log files samba as well as sshd …


Hi @gerald_FS

Some questions:
The server is real or virtual?
Nethserver is configured as a domain?

Yes it is a real server, and it is set up as Samba DC with its own domain.

The name resolution also works, except for the file release …

I’m no expert (usually use windows DC).
During the tests I had similar problems. Once the sssd service had not started, once the dhcp had not passed the proper dns

If you run only


Nethserver shows you your shares?

Perhaps @flatspin can help you

No, no releases are displayed.

Even if I want to manually integrate it is only with the IP address.

No service has been terminated.
If I integrate you with the ip address does not work all the file right …

SSSD           -ok
NSDC           -ok
SMB            -ok
DNS & DHCP    - ok (the addresses are also assigned correctly by the DHCP service)

The problem is solved!

The system or I was lost when the network interfaces were rolled up.
Therefore, two red interfaces were defined and not green.
In the GUI it was correct but they have behaved wrong.
Once reinstallation and then went again - all interfaces reconfigured and it went.


1 Like

Thank you for your feedback @gerald_FS :+1: