Samab DC & SSSD - Problems!

I still have the problem that I can not set up a new machine with 7.2RC2 and Samba DC.

If I install the Samba DC then this can not be established, GUI remains at 57% simply stand.
When the packages are downgraded, there is no change!

On Saturday, December 10th, it was still, since the larger update, it is no longer possible to set this up properly with new machine set-up.

This is quite bad!

Is there any solution, wait for the next version is unacceptable!


No Gerald not yet. Giacomo is working on it. The problem is that samba provisioning fails with upstream packages. Please see thread Provisioning fails with EL 7.3 Sorry cantvl give link I’m on smartphone. BR Ralf

I already read this!

I have great respect for what is being done here!

But unfortunately you can test nothing further and it is a simple downgrade it is not done first.


Have you tried the new package? It works for me.
yum --enablerepo=nethserver-testing update nethserver-dc

Hi Filippo,

sorry, but I don’t get it baken. What are the right steps to install this package?
If I install it directly without installing the package from the base repo it’s like no package is installed. I can choose LDAP or AD as provider under users&groups (see 2nd pic). If I install the baserepo package it’s this:

after installing update it’s this:

after yum downgrade nethserver-dc 1st screen appears again.
Installation steps done: 1. install from iso rc2, 2. update to el 7.3, 3. install nsdc.
Now I’m confused. :confused: What am I doing wrong?

1 Like

Please be patient, we’re releasing RC3!

Once the ISO will be available, the most easy way to solve @gerald_FS issue is reinstall from scratch 7 rc3, because the nethserver-dc installation failed and requires some manual steps to recover it. I guess it is a new installation, so the best thing to do is reinstall.


Long live GnR :smile:

Hi @gerald_FS, do you think this issue is solved by rc3? BTW, we’ve probably another bug on rc3, but this is another story…

Hi Davide,

I also had the problem like gerald_FS.
With the RC3 of Nethserver7 but it looks so that it now works.
I have been able to set up AD with Samba without problems on a new NS7 RC3 installation.