S20nethserver-ibays-set-permissions #2 (Exit Status 256)

System Version
NethServer release 7.5.1804 (final)

im getting this message when trying to create a smb network share. I´m not really firm working with nethserver and got to support this installation, which was a while back.
At some point it was possible to create shares, because some exist.

Need help plz.

From /var/log/messages:
Jan 25 11:31:42 nethsrv esmith::event[16279]: Action: /etc/e-smith/events/ibay-create/S20nethserver-ibays-set-permissions FAILED: 1 [0.180695]

Welcome to the forums.
What are the permissions of ibay directory and its subdirectories?
Are the shared folder on the default location or redirected to another drive/partition?

ls -hal /var/lib/nethserver/ibay/

I guess at some point you plan to update the server to the latest NethServer version.


[root@nethsrv ~]# ls -hal /var/lib/nethserver/ibay/
total 16K
drwxrwxr-x   7 root root                          82 Jan 25 12:11 .
drwxr-xr-x. 12 root root                         158 Oct 16  2018 ..
drwxrwsrwx+  6 root root                          92 Nov 22  2018 apptwo
drwxrws---  45 root buchhaltung@FQDN            4.0K Dec 15 11:15 Buchhaltung
drwxrws---+  4 root root                          38 Jan 25 14:32 CAD
drwxrws---+ 32 root domain users@FQDN           4.0K Jan 12 15:33 Dokumente
drwxrwsr-x+  6 root root                        4.0K Jan 25 12:49 Install
[root@nethsrv ~]#

I wanted to create the CAD-Share, which it creates, but it seems it has some issues with the AD-Groups.
Could not access is it with a user from the CAD group.
I found a workaround, but this is not really the way to go:

Owner: domain-users,
No write privileges for Owner Group
No Guest read/writes
read/write ACLs set to each user seperately (although they are all in AD Group CAD).

Still got the error while changing the properties of the share, but at least my users can now use it.

While i set the owner to the CAD group and granted write-access for the ownergroup i could not access the share.

Setting the owner to Domain-Users and setting read/write ACL access for the CAD group it also wouldnt let me access the share.

At some point maybe. Right now i´m scared that this will break everything. As i said, i´m not really deep into the NethServer stuff. And an error while creating a simple share doesn´t really push my confidence and trust in the product. ¯_(ツ)_/¯



Maybe, even most likely, the issues you are having have been solved long since…
I am running about 25-30 NethServer on Proxmox for my clients… :slight_smile:

Do yourself a favor: Do a complete Backup of your Server, then update it to the latest and greatest!

My 2 cents

Try resetting the permissions of the share with this command (or from the button present on the share section from the old server manager (https://YOURSERVER:980) ):

signal-event ibay-reset-permissions CAD


i allready tried that today.
The same error Message appears.


working on an outdated installation maybe an outdated issue is the problem?

Above anything else, this just strengthens my fear that an update will break everything…
Also, I really don´t see how this correlates with my issue.
The existing shares work fine and as expected, the issue just arises when i´m creating a new share or try to change the access rights on that new share.
For sure, in this state, i will not try to change the working ones.


1 Like


Hi Horst

Use Clonezilly, make a complete 1:1 clone of your server.
Shut down the server and disconnect the internal disk (Or put it aside).
Check if the clone disk works as the original.

You now have a complete save / clone / copy of your server on an “emergency” disk.

Test that both disks work (After the other).

Once you’re sure, then UPGRADE your old server!

-> You’re on the safe side with 2 identical disks!
You can “roll back” anytime, if it does not work.

My 2 cents

Hi Horst, the problem is we can not even try to reproduce your issue right now and also we do not know in which “state” the setup is.

So running the signal-event nethserver-samba-update will at least (re)configure the samba configuration as set in the server gui.
It does not install new software, it reads all the existing settings and rewrites the configuration files accordingly.

In an effort to figure out what could be your issue looked back at commits to the nethserver-samba module

And the mentioned issue stood out in time and description.
Even though I am pessimistic we can figure out what is happening lets check some versions to get some kind of feeling in which state the machine is, can you post the output of:

rpm -qa | grep samba

rpm -qa | grep nethserver-dc

cat /etc/redhat-release

EDIT: just to be sure:

alternatives --list | grep libwbclient