Running Subsonic on Nethserver


(Cas Nuy) #1

I am new to Nethserver, coming from Clearos. Since I had to upgrade my serverhardware in order to possible move to Clearos 7, I looked at alternatives and found this product. At first sight very promising so I am testing this setup. I want to run Subsonic througfh this box which is working fine on my Clearos 6.6 box.
The installation on Nethserver wnet pretty smooth, the Java SDK appeared already present and installing the RPM was a breeze. I run this application over port 8081 under a different user (not root but simply a user called subsonic).
I can see that the service is started but if i try to access the webpage, I get a page not found.
Anyone have a clue what the problem could be?
I tried running as root but that made no difference.
Do I need to open some ports and if so, how does this work uner Nethserver?
Hope you guys (or ladies) can help me out.
Thanks in advance from a very interested user in the Netherlands,
Cas


(Giacomo Sanchietti) #2

You should open the firewall port:

config set fw_subsonic service status enabled TCPPorts 8081 access public
signal-event firewall-adjust

For more info see: http://docs.nethserver.org/projects/nethserver-devel/en/latest/services.html#add-a-new-network-service


(Alessio Fattorini) #3

Ehi man, welcome on NethServer Tribe! Would you like to add more details about yourself here?
Glad to see another Clearos friend, would you mind to chime in this discussion?

Keep us in touch, do you have resolved your issue thanks to @giacomo advice?


(Cas Nuy) #4

I did try the advice of Giacomo but unfortunately no go yet ( I can always disable the firewall to determine root cause). In addition I found that another product I was evaluating (Piwigo), showed very strange behavior compared to Centos/Clearos. Still evaluating the various options, so actually trying to make a choice between Clearos/Centos/Nethserver.
My usage primary will be Mail/Web/Media server so no direct need for the security functionality Nethserver is offering.
At the moment I am testing vanilla Centos to see how things progress but I may come back to this flavour.


(Adam) #5

Not NethServer related, but I recently setup an install of CentOS 7 running Guacamole, ownCloud, and SubSonic for my home. It all works great together. Let me know if you have any questions.


(Alessio Fattorini) #6

That’s cool! Please open a new topic! I’d like to work on Guacamole on NethServer 7


(Cas Nuy) #7

I am currently looking @ Centos 7 and so far have no issues with Axigen, Subsonic etcetera.
Will have a look at Guacemole, already found a clear installation instruction on the web.