Rspamd authenticated user skip checks

NethServer Version: NethServer release 7.6.1810 (final)
Kernel release: 3.10.0-957.10.1.el7.x86_64
Module: rspamd-1.9.1-1.x86_64

Can someone guide me through setting up rspamd to skip checks for outgoing mail sent from a particular email address, I also want to disable ratelimiting, and I do want the mails to be DKIM signed.

Ratelimiting is not enabled iirc

https://rspamd.com/doc/modules/ratelimit.html

To make specific settings for one user

https://rspamd.com/doc/configuration/settings.html

Iirc we use a template for this, you probably need to make a custom template

Rspamd doesnt care to sign with dkim, so no problem

After some searching I came across this FAQ https://rspamd.com/doc/faq.html#can-i-just-sign-messages-using-dkim

# nano /etc/rspamd/override.d/settings.conf

settings {
sign_id {
id = “dkim”;
apply {
symbols_enabled = [“DKIM_SIGNED”]; # add ARC_SIGNED for ARC signing
flags = [“skip_process”]; # To skip message processing
}
}
sign_authenticated {
authenticated = true;
apply {
symbols_enabled = [“DKIM_SIGNED”]; # add ARC_SIGNED for ARC signing
flags = [“skip_process”]; # To skip message processing
}
}
sign_networks {
ip = [“172.16.0.0/16”, “10.0.0.0/8”];
apply {
symbols_enabled = [“DKIM_SIGNED”]; # add ARC_SIGNED for ARC signing
flags = [“skip_process”]; # To skip message processing
}
}
}

# systemctl restart rspamd

Nethserver uses opendkim to sign outbound emails with a UI panel, I do not get why you want to use rspamd to sign email. Please could you explain your problem and not the solution you found

According to Rsapmd control panel my Throughput is:
Average, msg/min: 1.13317
Maximum, msg/min: 6.32772
Last, msg/min: 5.66064

I figured removing the checks from rspamd would increase my throughput. I have installed mautic (a email marketing software) my contact list has 10,431 individuals.