Roundcube spell-check not adding words

System version
NethServer release 7.6.1810 (final)
Kernel release

I enabled spell-check in the roundcube config and whenever I send an email it flags my last name as not being correct. I left click on my name with the red line under it and the spell check box comes up. My last name isn’t anything on the list, I then click on the line with my last name in it and I then click on OK. When it goes back to the outbound e-mail I now see a green line under my name. When I do another outbound e-mail it again flags my last name being misspelled. Am I trying to add words to the dictionary the wrong way, is something broken or I should just I admit that don’t know what I’m doing and go back to yahoo mail? :grinning:

By clicking OK you just allow the word for the actual mail.

The dictionary has to be enabled first, then you get the “Add to dictionary” option:


To enable it you have to create a custom template to make the configuration permanent:

mkdir -p /etc/e-smith/templates-custom/etc/roundcubemail/

Create /etc/e-smith/templates-custom/etc/roundcubemail/ with following content (just one line):

$config['spellcheck_dictionary'] = true;

That way every user has its own dictionary. You may use ‘shared’ instead of ‘true’ to get a shared dictionary for all users.

Apply the config changes:

signal-event nethserver-roundcubemail-update


THAT did the trick, tyvm!