Roundcube offers xxx@ad.mydomain.tld, but I want xxx@mydomain.tld

roundcubemail
mail

(Jim Richardson) #1

NethServer Version: NethServer release 7.5.1804 (final), Kernel release 3.10.0-862.11.6.el7.x86_64
Module: Mail , Roundcube, ldap

I am a neophyte regarding mail servers.
I installed Nethserver, Print server, File server + active directory accounts. I created some test accounts . All is working well for Windows domain logins and Windows Active Directory file sharing. This server will not be connected to the outside world for email purposes - all email will be internal only.

I installed Roundcube. Roundcube lets me choose to login to Local or mydomain.tld . I login as YYY@mydomain.tld.

I want to send a test email to XXX@mydomain.tld but the address drop-down box only offers me the suggestion of XXX@ad.mydomain.tld [ the Public LDAP account ]
Obviously I can manually edit this address to the one I want, but my question is , how do I alter the behaviour so that users can either login easily to their user@ad.mydomain.tld email account, OR Roundcube offers the email address list of users@mydomain.tld in the dropdown?
I hope this makes sense


(Markus Neuberger) #2

It seems roundcube uses the AD username as mail address and identity and saves it in it’s database as soon as a new user logs in.

Do you use local Active directory or did you join to a remote AD?

Does your domainname contain the ad like ad.domain.tld?

config show DomainName

Do the AD users have the @ad.domain.tld in the username?

/usr/libexec/nethserver/list-users

Is your mail domain correct?

db domains show


(Jim Richardson) #3

This is a standalone server, using the Samba Active directory as the Accounts Provider

config show DomainName -> DomainName=wxyz.tld [ no ad. prefix ]

/usr/libexec/nethserver/list-users -> output of users who appear as user@wxyz.tld [ again, no ‘ad’ ]

db domains show -> wxyz.tld=domain
AlwaysBccAddress=
AlwaysBccStatus=disabled
Description=
DisclaimerStatus=disabled
TransportType=LocalDelivery
UnknownRecipientsActionDeliverMailbox=
UnknownRecipientsActionType=bounce


(Mark Verlinde) #4

What you want (xxx@mydomain.tld being default e-mail address) is expected behavior.

In an attempt to reproduce your issue it is the behavior overhere.
In other words, did not succeed to reproduce it. No matter how the test_users login for the first time or afterwards; with or without domain suffix (ie xxx@mydomain.tld or just yyy) the right and expected e-mail address (xxx@mydomain.tld withot ad.) is configured in Roundcube.

You can mitigate the issue in Roundcube by editing the address in Settings > Identities > Email for each user, but this is not an acceptable solution!

Very strange. :thinking:


(Jim Richardson) #5

Thanks for the responses. I will uninstall Roundcube and then reinstall it to see if the behaviour continues.


(Mark Verlinde) #6

Still trying to reproduce it and following your sequence of installing discribed in “where are you working on” eg CUPS > FileServer > AD.
this throws an error (failed to exapand krb5) here after installing AD:

Did you install the Mai-Server separately from Roundcube or did the Mail-Server get installed as an depenecy of Roundcube?

Did you do an update in the processes?


(Mark Verlinde) #7

Assuming you are in the test phase and do not have relevant data on you server you may drop the data-base of roundcubemail before reinstalling it:

mysql --defaults-file=/root/.my.cnf -e "DROP DATABASE roundcubemail"
rm -rf /var/lib/mysql/roundcubemail

NOTE ALL roundcubemail data will be LOST !!!

Still works as expected here: did no updates and pulled in the mail-server as dependency of roundcubemail.


(Markus Neuberger) #8

I also tried to change the LDAP field (userprincipalname) and the roundcube config (mail_domain) without success. I could not reproduce having the “ad.”-prefix in roundcube mail address or identity.


(Jim Richardson) #9

Yes, I’m in the testing phase… will be for awhile…
Anyhow the remove and reinstall has solved the issue and I can now login by entering the user name, and the drop-down address just offers recipients in the form recipient@mydomain.tld , which is what I wanted and we expected… I really don’t know what led to the initial problem, because I really didn’t do anything different in choosing and installing the module the second time.
I will retrace my steps more thoroughly to think about what may have happened… so that it won’t happen to others, but it’s all good now :grinning: Thanks again…