Restore files from gui is empty

backup

(EnzoC) #1

Even though there are more important issues these days, I would still ask for duplicity

Since I have activated duplicity, the swap is saturated. from command I have retrieved files, but from web admin the folders are not displayed.

On another server works perfectly.
is it just a ram problem? 64Gb ???

===== Report for data backup =====

Backup started at 2017-09-17 09:00:01
Pre backup scripts status: SUCCESS
Post backup scripts status: SUCCESS
Backup status: SUCCESS
Backup ended at 2017-09-17 10:28:28
Time elapsed: 1 hours, 28 minutes, 27 seconds

Disk Usage:
      Size       Used  Available     Use%
   2.69 TB    1.28 TB    1.27 TB    47.6%



Extract from log file /var/log/backup-data.log:

2017-09-17 09:00:01 - START - Backup data started
2017-09-17 09:06:59 - STEP - pre-backup-done done
2017-09-17 10:27:11 - STEP - backup-data-duplicity done
2017-09-17 10:28:28 - SUCCESS - Backup done




Extract from log file /var/log/last-backup.log:

Reading globbing filelist /tmp/gjGnI523FN
Local and Remote metadata are synchronized, no sync needed.
Last full backup date: Sat Sep  9 23:08:02 2017
--------------[ Backup Statistics ]--------------
StartTime 1505632055.71 (Sun Sep 17 09:07:35 2017)
EndTime 1505636721.43 (Sun Sep 17 10:25:21 2017)
ElapsedTime 4665.72 (1 hour 17 minutes 45.72 seconds)
SourceFiles 2062773
SourceFileSize 1026269266401 (956 GB)
NewFiles 849
NewFileSize 13191157 (12.6 MB)
DeletedFiles 184
ChangedFiles 487
ChangedFileSize 319774875574 (298 GB)
ChangedDeltaSize 0 (0 bytes)
DeltaEntries 1520
RawDeltaSize 651520703 (621 MB)
TotalDestinationSizeChange 130372295 (124 MB)
Errors 0
-------------------------------------------------

(Filippo Carletti) #2

I saw the same problem once, in a system where there were some external nfs filesystems mounted and a lot of empty directories. The list of files to restore is built by your web browser, did you try different browsers?
If you can share (send me) the full list of files on your server we can help, but I understand that it will be hard.


(EnzoC) #3

Yes…Firefox and Chrome

But then the problem is only for NFS?
With CIFS sharing there is this problem?
We’re still talking about the corporate file server … thousands of files, a lot of nested directories.

[root@samba ~]# backup-data-list > file.txt
[root@samba ~]# ls -lah file.txt
-rw-r--r-- 1 root root 219M Sep 19 12:26 file.txt

impossible to open :astonished:

What advice between NFS and CIFS for better performance?


(EnzoC) #4

I would…but I can not!
however, over 2M of backed up files, I do not think we have many empty folders

This is an example of longest directory backupped
Many space is a problem? :confused:

Sep 18 14:48:12 2012 var/lib/nethserver/ibay/dwg/Dati Commesse/Folderfold 250 Folderfold New Ver/Materiale Folderfold/MODELLI Riferimento Folderfold/Materiale Folderfold Scaricato/Materiale Folderfold/Telaio FD - 2620606/Nuova cartella/DEFAULT-55-1.sldprt


(Paolo Fornara) #5

Hi there, any update about this issue ?

I’ve same problem…no files list on restore panel, only folders. Im using an old Buffalo Nas with cifs share for backup.

/var/log/last-backup.log

--------------[ Backup Statistics ]--------------
StartTime 1525734012.81 (Tue May 8 01:00:12 2018)
EndTime 1525736394.46 (Tue May 8 01:39:54 2018)
ElapsedTime 2381.65 (39 minutes 41.65 seconds)
SourceFiles 91436
SourceFileSize 27875174073 (26.0 GB)
NewFiles 91436
NewFileSize 27875174073 (26.0 GB)
DeletedFiles 0
ChangedFiles 0
ChangedFileSize 0 (0 bytes)
ChangedDeltaSize 0 (0 bytes)
DeltaEntries 91436
RawDeltaSize 27870971759 (26.0 GB)
TotalDestinationSizeChange 18296139379 (17.0 GB)
Errors 0

backup-data-list command works right and prints out every file and folder into the archive.

No error on httpd-admin/error log (I was thinking about a timeout retrieving files list…but no errors logged) nor access log.

/var/log/backup-data.log :

2018-05-08 01:00:01 - START - Backup data started
2018-05-08 01:00:12 - STEP - pre-backup-done done
2018-05-08 01:41:06 - STEP - backup-data-duplicity done
2018-05-08 01:41:09 - SUCCESS - Backup done

PS: Already tried several browsers (Chrome, Firefox, IE, Edge and last but not the least…Safari…all were updated to latest version).

any ideas ?

King Regards and thank you for your support

Paolo


(Filippo Carletti) #6

This is the normal behaviour. You have to restore the whole directory and pick the files you need.
The web ui will never show files.


(Paolo Fornara) #7

Filippo, Thank you so much for your kind and quick reply !

Have you ever take in consideration to make a file level restore option ? It could be useful with huge sized folders.

Regards (from Italy)

Paolo


(Filippo Carletti) #8

Use the restore-file command to restore single files.


(Paolo Fornara) #9

I’ve found a new issue…trying to restore a complete folder. Restore complete without error on gui but if i check:

/var/log/restore-data.log:
2018-05-08 13:39:18 - ERROR - Restore failed, see /var/log/restore.log for details - 4864
2018-05-08 13:42:11 - ERROR - Restore failed, see /var/log/restore.log for details - 4864

/var/log/restore.log:
Local and Remote metadata are synchronized, no sync needed.
Last full backup date: Tue May 8 01:00:12 2018
–file-to-restore not found in archive - no files restored.
Local and Remote metadata are synchronized, no sync needed.
Last full backup date: Tue May 8 01:00:12 2018

The weird issue is that restored folder (and its content) are in place (i’ve also verified md5sum against original files to be sure) correctly.

It happens with booth “Restore files in the original path” or “Restore files in new directory” options.
I’ve also tried to restore folders with and without space in their name. Same bevahviour.

Any ideas?

Regards

Paolo