Restart NAS without affecting vm/windows+sqlserver on Proxmox

I quick question, related to proxmox + nas + vm/windows+sqlserver

Imagine that I need to restart the NAS where the vm is stored.
I wonder if I can pause each VMs running on proxmox+nas and wait for the nas to reboot, then just unpause the VMs without any loss? Especially for those VMs running sql server.

BTW, I have a test VM (windows 2012 r2 + sql server 2008 r2) , that I paused for some minutes, even days and I remember to not perceived any bad effect; of course, the vm is almost not used by anyone just for me for some migrations test.

I’m preparing for when I use a productive VM for our payroll system. (w201x+sql201x)

On second thought, I think the most sensible thing would be to turn off the MV and not play with fire.
I was curious, because just tonight I need to restart the NAS, to see if it shows an application I installed that doesn’t show up to assign permissions.

Sorry for highjacking this topic.


Hola Enrique!

As I’ve mentionned before: I use mostly Synology NAS at my several clients.
These NAS do get updates, maybe 6-9 a year - and these DO need reboots.

Now, your question IS a legit, intelligent question.
If you have heavy traffic, you can do a script which will do the “pausing” for you…
That would be the cleanest way.

But, to be honest, I’ve simply set my Synologys to do the updates automatically over the weekends at 3:00 early in the morning. This takes 2-3 minutes at most. Proxmox can cache the writing to NFS for that amount of time - no one notices!

Additional Note:
My VM Backups are all finished before 03:00, so I’m still on the safe side!

My 2 cents


:astonished: wow!
Thank you!

One thing I notice with my nethserver VM is that sometimes the VM doesn’t stop when I shutdown it from the GUI, and if I don’t watch and ask the Proxmox Server to restart, it can take as long as 15 minutes (hopefully) or wait forever.
I learned this the hard way, that time I had to run to the office at night and see the server that had already rebooted after +40 minutes.
Having learned this, I now check the VM and if I see that after N minutes it doesn’t shut down, I force the shutdown with “# qm stop 100”

The Zabbix Monitoring (Synology Template) will inform me beforehand that the Synos expect an update, so I am informed.

And we are talking about 25-30 NethServer on Proxmox environments, most also have / use a Windows (member) server for certain tasks/apps.

Stable for more tha 4 years, using Proxmox and Shared Storage on NFS/NAS.

Be sure to always install the QEMU-Guest-Agent - this is much more reliable than a simple ACPI reboot/shutdown!

On NethServer, the issue is often a fail2ban still running.

I also set this for all VMs:

For LXC containers I use 30, respectively 60…

My 2 cents

1 Like

Yes, is installed:

Package 10:qemu-guest-agent-2.12.0-3.el7.x86_64 already installed and latest version
Nothing to do

Who knows why my VM that sometimes does not turn off from the GUI?

This is the only VM in production right now, I don’t remember why I put 150 for the startup, something was happening that was the best for this vm.

Check the VM console on Proxmox (Do a planned reboot just to correct this!)…

In my cases, it was often the fail2ban service.
You may need to click in the proxmox console for it to actually show something, but you will see there what’s blocking your reboot/shutdown!

But with the forced shutdown after 180 seconds / 3 minutes, it works well!

Thanks for the advice, I’ll try to check it out the next chance I get. :+1: