Resolving domain name on intranet

NethServer Version: NethServer release 7.3.1611 (Final)
Module: DNS

Hi Everyone,

I installed a fresh NS7 final on a laptop to test out.
The internal network is behind a pfsense. NAT Port 80 and 443 is pointing to the nethserver internal IP.
Installed the following components:

Account provider: Samba Active Directory
File server
FTP server
Instant messaging
MariaDB (MySQL) server
SOGo groupware
Virtual machines manager
Web server

If i go to “Applications” on the GUI and click on “open” at each, they all open a new tab with the relevant page with the internal IP address.
Tested from external network with (i.e they all work.

Now my problem is that on the internal network non of the applications work with
Entering or returns “Unable to connect”.
If i enter the hostname that i set during setup (, then they all work. This is not the best cause like this email accounts setup on phones wont work, or the nextcloud sync app wont work either on the intranet.
I tried to set under DNS in the GUI a host pointing to the Server IP Address, but that results in an error Page when i go to “Users and goups” presenting the error: Account provider connection refused.
Same happens if i set the server alias instead. When i remove the host or the alias, then the “Users and goups” work again, but have the same problem then before with
Runnig a tracert it does 1 hop to the IP of the Dc i used during setup of samba.

Can anyone please help me how i can achieve that the resolves to the IP address of the server on the intranet?


I have NS 7 running and under configuration go to DNS. There you should be able to add a DNS record. I have a few records added on my system:

If I would run a website on the server I can perfectly add record for www.domain.tld that points to the server.

1 Like

Hi Rob,

Thank you very much for the response.
Maybe there is no issue just my lack of networking knowledge. I tried to add the DNS record in the format of That works, but i wanted to avoid that i have to type the url with the www prefix, though i never tried if it would resolve without it. I am away now, but will test later.


If you want to reach your internal website through http://domain.tld you have to set your website (or alias) vhost info. Have a look at and look for: ‘Define custom virtual host’.

Hi Rob,

As far as I understood the virtualhost is only if I would like to have multiple domains on the same server. Though this is not my intention, I gave it a try.
I assume that the nethserver equivalent doc is this:

I created a virtual host and unticked the option that it creates an alias:

Tried to access from intranet, but still “unable to connect”.

I searched on the nethserver and found the file /etc/httpd/conf.d/virtualhosts.conf.
The structure looked the same as in the article you gave me, so despite the warning I modified it and rebooted the server.

Both, and were inaccessible, so I reverted the change I made and rebooted again. If I create the the alias under DNS, the is accessible:

But then I am unable to access Users and groups:

Active Directory DNS sets an A record for the domain itself that points to DC IP. By overriding it the Server Manager cannot contact the LDAP server.

Go to Accounts provider page and under Advanced settings change the LDAP uri field. Substitute the domain part with the DC IP address or its FQDN.

Something went wrong if i do not see the advanced settings?

1 Like

You’re right: when a local AD accounts provider is installed, that page does not have “Advanced settings”.

You have to type some commands on the Bash shell:

config setprop sssd LdapURI ldaps://$(config getprop nsdc IpAddress)
signal-event nethserver-sssd-save

I am so happy, i nearly jumped out of my trousers. After fiddling around for days, this worked like a charm :slight_smile:
Setting the domain as host didn’t work, but as alias did. I created a host entry in DNS with a different domain name pointing to the NS, and that worked too, just to make sure host setting works in general.
Thank you very much for the great help :slight_smile: