Repodata: [Error 14] HTTP Error 404 - Not Found

Hi, I don’t know if the problem is the same but I have something similar. What can I do from a shell?

I think it’s a different error (it’s looking for some repodata files that are no longer in the repository). The post was moved from 10/10/19 Cannot find a valid baseurl for repo: ce-base/7/x86_64 to a new topic.

You can try to solve the problem using these commands from the CentOS wiki:

yum clean all
rm -rf /var/cache/yum/*    # warning: take extra care when running an rm command

[root@neth7 ~]# yum update
Loaded plugins: changelog, fastestmirror, nethserver_events
Loading mirror speeds from cached hostfile
epel/x86_64/metalink | 22 kB 00:00:00

  • epel:
    ce-base/7/x86_64/signature | 811 B 00:00:00
    ce-base/7/x86_64/signature | 3.6 kB 00:00:00 !!!
    ce-extras/7/x86_64/signature | 811 B 00:00:00
    ce-extras/7/x86_64/signature | 3.4 kB 00:00:00 !!!
    ce-sclo-rh | 3.0 kB 00:00:00
    ce-sclo-sclo | 2.9 kB 00:00:00
    ce-updates/7/x86_64/signature | 811 B 00:00:00
    ce-updates/7/x86_64/signature | 3.4 kB 00:00:00 !!!
    epel | 5.4 kB 00:00:00
    nethforge/7/x86_64/signature | 836 B 00:00:00
    nethforge/7/x86_64/signature | 4.1 kB 00:00:00 !!!
    nethserver-base/7/x86_64/signature | 836 B 00:00:00
    nethserver-base/7/x86_64/signature | 2.9 kB 00:00:00 !!!
    nethserver-updates/7/x86_64/signature | 836 B 00:00:00
    nethserver-updates/7/x86_64/signature | 3.6 kB 00:00:00 !!!
    stephdl | 2.9 kB 00:00:00
    nethserver-updates/7/x86_64/pr FAILED [Errno 14] HTTP Error 404 - Not Found
    Trying other mirror.
    To address this issue please refer to the below wiki article

If above article doesn’t help to resolve this issue please use

nethserver-updates/7/x86_64/pr FAILED [Errno 14] HTTP Error 404 - Not Found
Trying other mirror. [Errno 14] HTTP Error 404 - Not Found
Trying other mirror.

One of the configured repositories failed (NethServer-7.6.1810 - Updates),
and yum doesn’t have enough cached data to continue. At this point the only
safe thing yum can do is fail. There are a few ways to work “fix” this:

 1. Contact the upstream for the repository and get them to fix the problem.

 2. Reconfigure the baseurl/etc. for the repository, to point to a working
    upstream. This is most often useful if you are using a newer
    distribution release than is supported by the repository (and the
    packages for the previous distribution release still work).

 3. Run the command with the repository temporarily disabled
        yum --disablerepo=nethserver-updates ...

 4. Disable the repository permanently, so yum won't use it by default. Yum
    will then just ignore the repository until you permanently enable it
    again or use --enablerepo for temporary usage:

        yum-config-manager --disable nethserver-updates
        subscription-manager repos --disable=nethserver-updates

 5. Configure the failing repository to be skipped, if it is unavailable.
    Note that yum will try to contact the repo. when it runs most commands,
    so will have to try and fail each time (and thus. yum will be be much
    slower). If it is a very temporary problem though, this is often a nice

        yum-config-manager --save --setopt=nethserver-updates.skip_if_unavailable=true

failure: repodata/c10e048c44b0550712fc81343b437ad9f8a98c8a4919fcb358cd99b182c6ae9e-primary.sqlite.bz2 from nethserver-updates: [Errno 256] No more mirrors to try. [Errno 14] HTTP Error 404 - Not Found

What is the outcome of:

curl |grep 'primary.sqlite.bz2'
1 Like

The result is correct and it seems that now everything works without reporting errors. I need to investigate elsewhere probably on the http pfsense proxy firewall.


Most probably a proxy issue. I think you’re getting a cached file.
As of today the command outcome should be:

<location href="repodata/3a9b0c118c2ede28246dff68a3f9d11607b2cbcff639f6e37d68c4a8cd9764cd-primary.sqlite.bz2"/>

A possible trick for the proxy:

curl -H 'Cache-Control: no-cache'

Yum also has some settings to change how http cache is handled.

1 Like

Ok, anyway in version 7 I haven’t had any problems with the previous one, so I strongly suspect it was an error caused by the firewall proxy. I’ll see what happens in the next few hours … Thanks!

Hi, yum updates do not report an error but I received this email from the system.


Not using downloaded nethserver-updates / repomd.xml because it is older than what we have:
Current: Thu Oct 10 17:12:38 2019
Downloaded: Wed Oct 2 16:35:43 2019



Not using downloaded nethserver-updates/repomd.xml because it is older than what we have:
Current : Thu Oct 10 17:12:38 2019
Downloaded: Wed Oct 2 16:35:43 2019

yum/yum-cron has the correct current file but when it tries to check for updates it is getting an older version (most probably from a proxy cache out of sync).

To be sure of the diagnostic, you can compare the differences between /var/cache/yum/x86_64/7/nethserver-updates/repomd.xml file, and the ones you get when accessing, both from behind your proxy and also when bypassing the proxy.

To solve the problem you can empty the proxy cache.

If problem persists, take a look at yum.conf http_caching option (or try it live with yum --setopt=... command) after clearing the yum cache (and removing files from /var/cache/yum/*).

1 Like

Hi, I downloaded the repomd.xml file and verified any differences with diff. They are the same, I ran the update check again without errors and without upgrades available. Thanks for the moment .

Hi, after checking the pfsense firewall, the problem was not the neth7 server but the squid proxy cache managed by the firewall.