Repairing Nethserver


I have successfully installed Nethserver 7, have configured it according to my needs and everything worked fine. Then I wanted to install nethserver-wordpress provided by Stephane de Labrusse from the Wiki. But I had I PHP version conflict. Details see here So I have manually removed the php release 5.4.16-46-el7 and replaced it with 5.4.16-45-el7 using yum. But unfortunately this has broken my nethserver installation. So I do not have any access to the server manager using https://server_name:980. Do you have any idea or links on how to repair the installation?

I’ve tried already nethserver-install, but that tells me:

NethServer is already installed!

You can access the Web interface at: (or
Login: root
Password: <your_root_password>

Installation log can be found here: /var/log/nethserver-install.log

I can still login using SSH but as I said NOT During the removement of php-5.4.16-46-el7, yum reported me, that some nethserver modules are depended on it, and removed it. So I think, it should be somehow possible, to reinstall them.

Any hints on how to repair the Nethserver installation would be nice.

You may try to install/reinstall php:

yum reinstall nethserver-php php

Please check the status of the server manager and also check your network role (maybe mixed green/red) settings.

systemctl status httpd-admin -l

Danke Markus für Deinen Input. Lets continue in English :wink:, so everybody can read it.

Using systemctl status httpd-admin -l, I found out, that it is not started at all :frowning:

Unit httpd-admin.service could not be found.

So, I’ll to reinstall some other NethServer packages. I don’t know jet which ones, but I will do kind of trail and error.

I’ve tried:

yum reinstall nethserver-httpd-admin

Package(s) nethserver-httpd-admin available, but not installed.

yum install nethserver-httpd-admin

No Presto metadata available for nethserver-base
nethserver-httpd-admin-2.3.4-1 FAILED                                  [Errno 14] HTTP Error 404 - Not Found   ]  0.0 B/s |    0 B  --:--:-- ETA 
Trying other mirror.

Any idea what went wrong?

OK, I found out,that the required packages:
nethserver-httpd-admin-2.3.4-1 and

are located in:

So, my next question is how do I have to configure yum that it finds the appropriate repositories?

You shouldn’t need doing it since the script must configure a NS 7.6.
Could you please output the content of the following command?

  • cat /etc/centos-release
  • cat /etc/nethserver-release
  • rpm -qi nethserver-release

When I execute the obove commands, I get the following:

[root@sits ~]# cat /etc/centos-release
CentOS Linux release 7.6.1810 (Core) 
[root@sits ~]# cat /etc/netserver-release
cat: /etc/netserver-release: No such file or directory
[root@sits ~]# cat /etc/nethserver-release
NethServer release 7.6.1810 (final)
[root@sits ~]# rpm -qi nethserver-release
Name        : nethserver-release
Version     : 7
Release     : 12.ns7
Architecture: noarch
Install Date: Tue 18 Dec 2018 07:47:42 AM CET
Group       : Unspecified
Size        : 47306
License     : GPL
Signature   : RSA/SHA1, Mon 17 Dec 2018 09:44:02 AM CET, Key ID 9cb28ea039baf5c1
Source RPM  : nethserver-release-7-12.ns7.src.rpm
Build Date  : Mon 17 Dec 2018 09:43:57 AM CET
Build Host  :
Relocations : (not relocatable)
URL         :
Summary     : NethServer YUM repo configuration
Description :
NethServer YUM repository configuration

So the releases are correct.

I totally missed it! Probably you removed something important.
Make sure /etc/yum.repos.d/NethServer.repo is the correct one

When all repos are set, install the missing packages.

Yes, my /etc/yum.repos.d/NethServer.repo is correct:

# YUM repositories configuration

name=NethServer-$releasever - Base

name=NethServer-$releasever - Updates

name=NethServer-$releasever - Testing

When all repos are set, install the missing packages.

Yes I should know install the missing/removed packages. But this is quit tricky to find out witch ones have been touched/removed .

I’ve tried:

yum history

using differend parametes (info|list|summary) but without any success so far :frowning:

Any idea?

The correct usage is:

  1. list all transaction: yum history list
  2. find info about the transaction: yum history info <id>.

Make sure also you’re accessing latest release:

config setprop sysconfig NsReleaseLock disabled
signal-event software-repos-save

YES, that seems exactly what I was looking for. E.g.

[root@sits ~]# yum history info 20
Loaded plugins: changelog, fastestmirror, nethserver_events
Transaction ID : 20
Begin time     : Mon Dec 17 20:27:37 2018
Begin rpmdb    : 789:43bd56125995957d709a37ad377fd88e2b04625a
End time       :            20:28:43 2018 (66 seconds)
End rpmdb      : 784:7ae3e6de9bc0c27915fb08ca1eed97bb776c3e7f
User           : root <root>
Return-Code    : Success
Command Line   : remove php-common-5.4.16-46.el7.x86_64
Transaction performed with:
    Installed     rpm-4.11.3-35.el7.x86_64                      @base
    Installed     yum-3.4.3-161.el7.centos.noarch               @base
    Installed     yum-plugin-fastestmirror-1.1.31-50.el7.noarch @base
Packages Altered:
    Erase nethserver-php-1.2.0-1.ns7.noarch             @nethserver-base
    Erase nethserver-phpsettings-1.1.2-1.ns7.sdl.noarch @stephdl
    Erase php-common-5.4.16-46.el7.x86_64               @base
    Erase php-intl-5.4.16-46.el7.x86_64                 @base
    Erase php-xml-5.4.16-46.el7.x86_64                  @base
history info

Don’t know yet, if I will be able to repair Nethserver BUT it was anyway a very good practice in learning by doing so far :wink: I’ll give feedback as soon as I have hopefully good news regarding repairing. But I’m quite confident, that I’ll manage it. I should mention, that I’m a professional IT guy but as you’ve probably already realized, I am quite a beginner when it comes to Linux installation, package management and low level commands :frowning: I’m more at home in IT Project Management and in RT OSs and embedded systems.

I really like Nethserver, the available documentation and it’s Community, You Giacomo for example :smile: It seems to me, that you, I mean the hole development team is really concerned about the Nethserver users. I’m using Nethserver currently only at home, basically the Samba functionality as a NAS, speak I’m using only a fragment of the possible use cases, that could be realized with Nethserver. So, I’m currently setting up a 2nd, old Dell PC as my Webserver. I’m planing to have my personal but also my professional home site running there, but I would also like to test other possible features of Nethserver :grin::bangbang::interrobang:


I’ve good news. I’m finally able to access my Nethserver Manager again using:


But that was quite a bit of work :sweat_smile: Actually I was nearly at the point to reinstall the newest Nethserver from scratch - but that would have really hurt me. E.g. could not install

yum install nethserver-httpd-admin

So, I decided to attempt it a last time by just manually installing the RPMs:

yum install nethserver-httpd-admin-2.3.4-1.ns7.noarch.rpm
yum install nethserver-httpd-proxypass-3.2.7-1.ns7.noarch.rpm

To my surprise, that actually worked :slight_smile: and I could access the Server Manager. But the system was in an inconsistent state and a I had again to manually install/reinstall several Nethserver packages. E.g. I had to install nethserver-directories and some other packages too. They where probably removed during downgrading the php release from 5.4.16-46-el7 to 5.4.16-45-el7.

But finally, everything seems to work again as expected :bangbang::grin::bangbang::grinning:

Even WordPress is working :-). Have installed it according these wiki instructions:[]=wordpress provided by Staphane de Labrusse. Could do this after removing the php release 5.4.16-46-el7 and replaced it with 5.4.16-45-el7. OK, that was not a strait forward way to do it but finally I could install WordPress with the mentioned consequences at the very beginning of my topic.

And the server is quit fast:

As a summary I’ve learned a lot about yum, rpm and in general package management AND I’m really impressed how stable and robust the Nethserver actually is.

I’m now looking foreword to do some more productive work with Nethserver :bangbang: