--renew-hook signal event issues

NethServer Version: 7.9.2009
Module: Letsencrypt

I seem to have problems renewing my letsencrypt certificates, and as a result it is filling up my inbox with:

Unable to find renew-hook command signal-event in the PATH.
(PATH is /usr/bin:/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin)

I tried to troubleshoot the issue and I think its something to do either with Signal-event being on a different PATH or a permissions issue as even though signal-event comes up as executable with an ls -l, when I ran the command manually it tells me signal-event is not executable?

Any ideas?

Default PATH on NethServer as root user:

# echo $PATH

The cron job for updating letsencrypt certs seems to be executed by my user account on nethserver not root.
Is it better If I move the cron job to root, or do I change permissions on signal-event to allow users other than root to execute?


How did this happen?

I don’t know, I haven’t setup any cron jobs.
The only thing I have been trying to do is allow my user login on cockpit to have the same functionality as the root login, however most things still do not work under my user login to cockpit.



That won’t work! Even an AD admin will not have enough rights in Cockpit.

My 2 cents

There are some things from the server-manager that can be delegated to other users/groups, but not everything.