Remote database

mysql

(Bimoputra Pratama) #1

I installed Nethserver on the local computer then I have set the database password, why can’t I remote database via another computer on the same network?


(Mark Verlinde) #2

Did you make the mysql service / port available for the network zones you are trying to reach it from?
The default setting for mysql (port 3306) is to listen to the localhost and block request from red and green zones.

To change this setting go in the server-manager to (Security) Network services > mysqld (Edit)
and change allow access from zones to LAN (green) to mach your situation:

afbeelding


(Bimoputra Pratama) #3

I activated all of my Network Services on Nethserver to become lan and green, the problem is why go to the server manager, ssh, etc. so it’s slow then how do I set it up and all the Network Service lan and green?


(Mark Verlinde) #4

Nethserver is configured in a way it covers most user-cases and has security in mind. Hence some services are only localhost others green and some green and red.

This being said i have to add a warning to the advice I gave you:

The connection to mysql is not encrypted and with security in mind it access is limited the localhost by default. Please be aware communication to the databases over LAN (green) is not encrypted.


(Bimoputra Pratama) #5

I accidentally deactivated all red and green services on Network Service and finally I did not have any remote services via local ip, how do I fix them, do you have the default screenshoot?


(Mark Verlinde) #6

Do not know which nethserver modules you have installed, and i do not know the default settings of all the modules.

This is a screenshot with default settings of a basic test install running here:


(Bimoputra Pratama) #7

Ok, thank you all the info. It’s running normally again