Recipient address rejected: User unknown in virtual mailbox table


Hi everyone, I have a problem with Nethserver, I’m trying to set up two separate mail servers, one manages an aruba domain, the other one must manage some accounts.
My intent would be to configure the servers via the pop3 connector and its smarthost, since after creating users, set the mailboxes, and enabled pop3 connector, on the aruba domain i have no problems, i just had to configure stunnel for the smarthost ( NS6.9) and receive and send it to any domain without any problems. The problem arises with the domain, in fact, after performing all the procedures like for the aruba domain, I quietly download the mail, but if I try to send an email from the server that manages the domain to a libero account. Which is not configured on NS, I receive: “550 5.1.1: Recipient address rejected: User unknown in virtual mailbox table”. If I try to send to a domain that is not, the message is part and is delivered normally.
Could it be a DNS problem? If so, could you please tell me how to solve the problem? thank you so much.

You have to configure (email -> domain) to deliver emails externally and not locally

1 Like

Thanks for the answer, but honestly I did not understand, could you be so kind to explain me better?
Should I create a new domain?

The domain is already configured, I used the same settings I used for the Aruba account, obviously with its credentials, there is no way to tell nethserver that accounts are remote?

Yes, click on “relay to another server” and insert libero_ip

1 Like

Sorry alessio, I would not say stupidity, but I think the solution you gave me is not correct. My problem is that I can not send from domain configured with smarthost ( to other accounts that are not present on Nethserver but exist on the provider.
I believe your indications refer to incoming mail where through pop3 connector I have no problem, I’m confused. If I try to send to any domain (eg gmail, I have no problem, it is as if nethserver “only fish in its db users” I would like to search on @ (provider) I remain convinced that Whether it’s dns, or something.

Hi @p.mall, @alefattorini is right. If you have set the “” domain on your server, the mail for “” domain will be managed locally. Therefore, you can not send other users (only local users work).
For this reason you have to leave the relay of these mails to the real server of “

1 Like

Thanks for this, @enzoturri to my point my doubt has been resolved, but at the same time I had already tried to set in the domain settings the IP of the smtp server of @, however, I had the mail stays queued, looking at Log I find an authentication error that I can not explain, could you please be clearer? Thank you so much!

Nothing to do, if I put smtp of @libero in domain settings and even if i’m using smarthost, i get:[]:25, delay=1.4, delays=0.22/0/0.11/1.1, dsn=5.0.0, status=bounced (host[] said: 550 Authentication Required [smtp-17.iol.local; LIB_401] (in reply to MAIL FROM command))
Jun 17 10:56:48 srv03 postfix/qmgr[17104]: 3FE171800624: removed

I can not understand, authentication does not do it smarthost?
thank you. smtp server requires authentication.
If the mail is free, I think they do not offer smarthost service.
If your provider gives you one, you could try that with it.
In the extreme, you should configure the email client’s smtp to use

1 Like

Good morning, today I think I have found the solution, after your advice, I set relay to another server as server: “” and in the smathost settings i put: “” user / password And portsa 25, emails arrive quietly, obviously before I set up in the server relay: “” and in smarthost I had put:, reading the logs, I saw that he still kept the approach With 25, I revised the configurations by setting port 25 and putting at this time it works, thank you!


Great job. Thanks for update. :wink:

1 Like