Read-only filesystem, NetGUI broken for FireFox after update

nethgui
server-manager
v7

(Jeroen Visser) #1

NethServer Version: 7.5.1804 (beta)
Module: NetGui

EDIT: This issue was caused by 2 no longer supported mountflags and issues with cookies/offline data. Editing fstab solved the first issue, clearing FF cookies the second.

So, I googled this, and found a few topics that all give the idear that this issue should be gone. Yet, here I am. I had an old server laying around, and wanted to test the updates before running them on my live servers. I neglected to note the version prior to update, but my last kernel entries are as follows:

When booting from the default one, my filesystem becomes read-only. Booting the previous kernel works, except that my NetGui wont load in Firefox anylonger (while it will in IE)

Could anybody help me on the reason for the read-only filesystem ? The previous support tickets about this, seemed all to be resolved in updates that should be present in my system.

Also, any reason why I am running a beta all of a sudden ? (Could be my own fault, this server was a proof of concept and has been off for a while.)
afbeelding

The thing is, a quick snapshot of a similar server and a test gave me the same errors … I am hesitant to continue updating, but need to update in order to get my support going …

Is this an obvious mistake, configuration error, or something more serious ?


Access the web interface
(Jeroen Visser) #2

Solution: edit /etc/fstab and remove the mount options acl and user_xattr, if present. Both where in my case. Clear cookies and offline data for website (firefox issue was cleared by doing that)

In reply to @dnutan in another thread that seems similar but unrelated, he asked me to post my fstab, after my journalctl revealed the first error to be a mount option (acl):

…removed the obvious part from that file;

…removed the other (now) also obvious part (requiring reboot to previous kernel), and all seems well.
Need to see what this does for shares and the like.