Proxy Setup and config


(esseltre84) #1

Today i have tested the function proxy with some problem.
Information about the sistem and configuration (server):
Nethserver 6.6 (RC1)
Double Lan card (one for red zone and one for green zone)
Proxy enabled with authentication
Antivirus web enabled
Filter content enabled (i’d like block the download of file with exe extension)
Client setup:
OS: Win 8.1
Browser: FireFox 30.0.3
Ip config:
Lan ip for work in green zone,
Gateway and dns: ip of server on green zone.
So…
I have added exe extension on a block (filter content area) but if a try to download some exe file the block doesn’t work.
On firefox if i setup the browser for check in auto the proxy configuration i have permission to navigate in internet with no user and password.
Some help?
See y.


How to configure nethserver with 2 NICs
Webfilter is enabled with urlblacklist. But restircted sites still opens
(Alessio Fattorini) #2

Can try to navigate and copy/paste here /var/log/squid/access.log?


(Roberto Sitzia) #3

Hi @esseltre84
initially I had some problem, web filter didn’t block exe and zip files.

Plese check this

then go here

finally check that in the image below

and enjoy NethServer!

Bye


(esseltre84) #4

Hello sitz,
with your setup work great… the filter now is up… but If i setup my browser for check in auto the proxy configuration, i’m enabled to navigate with no authentication… on iexplorer and firefox to… and firefox completely ignore the web filter…
Could y try that? and after that i will need to check this setup for some other browser… for 1st crohome…
I read around that is not easy to prevent or limit the navigation on this browser


(esseltre84) #5

43 pages of log… have y some place where i can post my log on txt file?


(Roberto Sitzia) #6

Hi @esseltre84 have you tried to check option in the image below?

Enabling HTTP and HTTPS ports block even if clients have gateway and dns configured they cannot bypass the proxy.
I have tried with IE, Firefox and Chrome and in my case works fine.

Let me know.


(Haliparotin) #7

hi! i try to create and test NS Proxy but i need to configure each Computer or Browser to push to my proxy there is a way without config the each computer or browser?

Thank you :smile:


(Gabriel GHEORGHIU) #8

Hi,
You don’t need to configure every computer to use proxy.
Just set the browser for auto detection, usualy on default.

Please read this:

Or this:
http://wiki.nethserver.org/doku.php?id=howto:how_to_configure_web_proxy_in_transparent_with_ssl_mode

If you need more help, do not hesitate to ask!

BR,
Gabriel


(Alessio Fattorini) #9

Do you have sorted out?
Please check the @GG_jr’s answer marking the topic as resolved