Properties of shared folder not visible

NethServer Version: 7 rc3

New user here. I’ve tried in 6.8, 7rc3, and 7rc4 to share a folder. When I do the only properties available are name, description, browseable, and network recycle bin. No other options, no permissions, no other tabs, nothing.

What am I missing?

Thanks

You can configure an account provider. The extra permission controls are available after installing Account Provider: Samba Active Directory module (nethserver-dc).
You can find more details in the manual:
http://docs.nethserver.org/en/v7rc/accounts.html

1 Like

Thanks. Trying that now. Suggestion for the developers: more information needs to be make provided to users during setup of shared folders.

1 Like

Argh. I really can’t get anywhere with this. Whenever I try to do anything in the web interface it becomes unresponsive and then won’t load again until I reboot. I’m running nethserver as a vm in proxmox.

Again, this has been the behavior in any version of nethserver I’ve tried. I want to like nethserver, but something is making it really difficult.

Something wrong in /var/log/messages ?

can you see a processus eating the cpu of your server (see by top or htop)

Can you explain the story of your server, what you did, which version you installed.

How would you do it? What info are required?

Please help us to improve the user experience!

Did you install a local OpenLDAP account provider? Or configured a remote one? Or none?

I see nothing of any significance in /var/log/messages. CPU usage after the crash of the web ui is less than 1%.

Nethserver is a fresh install of 7rc3 running as a vm in proxmox with 2 cores and 2gb ram. I installed the windows server components and that’s it. Not much else to tell.

If an account provider is required, then it’s really a dependency for shared folders and the user should be presented with the option to also install it. If we must used a samba dc for it to work, let us know. If ldap will or won’t work, let us know.

I tried setting up the same on clearos, for example, and the process was much more informative. Maybe follow a similar process as clearos?

Essentially, I just expected it to work since I wasn’t presented with any other requirements, dependencies or steps in the setup process. When something doesn’t work I would hope to have the ui to let me know it isn’t working and provide some direction to fix it.

1 Like

This is the point: it is not strictly required. Shared folders work in guest mode without any account provider installed. However authenticated mode requires a samba back end, being it local or remote.

Now, how can we make a self explanatory UI? :thinking:

Do you have a screenshot?

No screenshots yet, but I’ll try to post one. I’ve setup another instance of NS in Parallels on my Mac. No crashing of the web ui but I’m still not able to access shares on either windows or mac. All I see is sysvol and netlogon, but not the folder I created.

Also, i don’t have a samba tab visible in shared folders.

This should be really easy guys.

I have just tested it in five minutes, but my clients are linux fedora, it works

Install nethserver-samba by the cli

I created a share ‘plop’, then I used nautilus to browse the ‘Workgroup’ and found my server, then I created a folder in the ‘plop’ share…worked as expected.

My only concern is that there is no dependencies between nethserver-ibays and nethserver-samba by the CLI install (nethserver-samba calls nethserver-ibays but not the inverse)

I agree: we ought to fix either RPM deps or group composition to make the uninstall procedure working correctly.

Those shares are typical of the DC, but the shared folder is not there: are you sure you’re typing the correct IP/hostname?

I agree with you: this is THE goal. You are here to help us, correct?

1 Like

I don’t know if it is relevant but we have had something close recently

I will try to reproduce with a rc4. I use also proxmox as virtualisation server…no much to say, it works well

I’m also curious, can you provide us some examples of that “much more informative process” ?
Thanks :slight_smile:

Alessio, I made a few suggestions above for additional info that could be added.

Also, I went back and checked ClearOS to see what info they had to compare and I think that after initial setup I can’t see that anymore. I’d need to recreate the vm from scratch and try again. When I get time I will do this to see what helpful info there is.

I can tell you that I’ve now tried at least 6 fresh installs of NS and I can’t get file shares to be accessible from Windows or Mac - and/or the web ui crashes and I can’t make progress.

By comparison:

Zentyal: Fresh install, setup “Domain (Samba DC)”, create a user and a group with that user. File sharing (“Flexshare setup as Windows File Sharing”) works as long as an ACL is created for the shared folder.

ClearOS: Fresh install, setup “Windows Networking (Samba DC)”, create a user and a group with that user. File sharing works without doing anything else.

Nethserver: Still trying…

Thanks stephdl. This does get the web ui running again.

1 Like

what did you do exactly please ?

I would propose something in the help page of the shared folder, relative to the user authentication.
We could add a chapter on the installation of nethserver-dc if you want a full control on the samba shares.

Here’s my most recent attempt today:

  1. Clean install of 7rc3
  2. Install updates
    2.5 Yum cache error while reloading software center, won’t clear, reboot
    2.6 More updates are available, install them
  3. Install Account Provider: Samba Active Directory & File Server
  4. Configure Samba Active Directory - create bridge device, set IP, click “Start DC” then more rpms install
  5. Create a new group
  6. Create new user. FYI, when choosing groups we should be presented with a list, not only a search field.
  7. Create a new shared folder. Owning group = group created above, write permission for group enabled, browsable
  8. Set ACL to read/write for group
  9. Try to access using IP from OSX. Only available folders are sysvol & netlogon.
  10. Set ACL for the new user to read/write. Only available folders are sysvol & netlogon.

FYI, I still have no SAMBA tab on the shared folder settings page like I’ve seen in other screenshots of this process.

So, no luck. Something is still wrong

I agree, it would be a good improvement

You should expect no “samba tab” in ns7. That was available in ns6.

Let’s see your setup. Assuming the network works correctly, could you paste also the output of

db networks show
config show nsdc
config show sssd
getfacl /var/lib/nethserver/ibay/*
account-provider-test dump

For instance on my machine:

https://gist.github.com/DavidePrincipi/0e06fa0d090c924fa82c7c249c0a4f08#file-shelloutput

Also note the output of smbclient -L with IP of host and container: netlogon and sysvol are typical of nsdc, whilst shares are created on NethServer host machine.

https://gist.github.com/DavidePrincipi/0e06fa0d090c924fa82c7c249c0a4f08#file-smbclient