Problems setting up a simple file server

Hi, All!

I am moving forward with my home server/fw - NS6.7

Now I would like to set up simple file server. Would be nice to have shared home directories for users + some common folders for group.

I installed “File server” addition.
In “Windows Network” I set “Workstation” and define workgroup used.
I have set up some users with “Shared Folders (Samba)” enabled.
I set up one shared folder, with “Samba enabled” and owner group is the one, where my users are defined.

I can not access the server from my internal network. :frowning:

Here is what I find in the logs:
Samba name server SERVELIS is now a local master browser for workgroup HOMENET on subnet

[2016/04/19 17:31:23,  0] nmbd/nmbd_incomingdgrams.c:311(process_local_master_announce)
  process_local_master_announce: Server MARTINS-KTA at IP is announcing itself as a local master browser for workgroup HOMENET and we think we are master. Forcing election.
[2016/04/19 17:31:23,  0] nmbd/nmbd_become_lmb.c:150(unbecome_local_master_success)
  Samba name server SERVELIS has stopped being a local master browser for workgroup HOMENET on subnet
[2016/04/19 17:31:40,  0] nmbd/nmbd_become_lmb.c:397(become_local_master_stage2)
  Samba name server SERVELIS is now a local master browser for workgroup HOMENET on subnet

Martins-kta - that`s my laptop. So I need to switch of the “master browser” in it.

In log.smbd
[2016/04/20 12:34:53.375515, 0] printing/print_cups.c:151(cups_connect) Unable to connect to CUPS server localhost:631 - Connection refused [2016/04/20 12:34:53.376128, 0] printing/print_cups.c:528(cups_async_callback) failed to retrieve printer list: NT_STATUS_UNSUCCESSFUL
That feels right - I do not have any printers connected, nor “Print Server” installed.

[2016/04/19 15:31:53.264420, 0] winbindd/winbindd.c:240(winbindd_sig_term_handler) Got sig[15] terminate (is_parent=1) [2016/04/19 15:31:54, 0] winbindd/winbindd.c:1382(main) winbindd version 3.6.23-30.el6_7 started. Copyright Andrew Tridgell and the Samba Team 1992-2011

Apr 19 00:48:55 Installed: samba-common-3.6.23-30.el6_7.x86_64 Apr 19 00:48:56 Installed: samba-winbind-3.6.23-30.el6_7.x86_64 Apr 19 00:48:56 Installed: samba-winbind-clients-3.6.23-30.el6_7.x86_64 Apr 19 00:49:03 Installed: samba-client-3.6.23-30.el6_7.x86_64 Apr 19 00:49:11 Installed: samba-3.6.23-30.el6_7.x86_64 Apr 19 00:49:27 Installed: nethserver-samba-1.5.4-1.ns6.noarch Apr 19 13:31:21 Installed: nethserver-samba-audit-1.0.5-1.ns6.noarch Apr 19 15:31:41 Updated: nethserver-samba-1.5.4-1.1.g4a6f07a.ns6.noarch

I have testing repo enabled

Some ideas?
Thanks, Martins

Please don’t edit your own post, add a reply and mark the topic as solved :slight_smile:

1 Like

I had a similar problem in the past .
For testing , you can change the registry key in windows 7

Go to:
(Before editing, backup it)

And set
IsDomainMaster to FALSE
MaintainServerList to No

If it does not exist create it
It worked for me

1 Like

Thanks @enzoturri ! I find out also, that I can reach server from green network with IP or full domain name.
So I added server as a WINS server in DHCP advanced settings, and now it works like a charm! :slight_smile:

Sorry @alefattorini - I will keep that in mind!