Problems migrating from SME to Nethsever

migrate
migration
v7

(paul_marwick) #1

I’m interested in moving a number of SME 9.2 installations to Nethserver. Installed nethserver-7.5.1804-x86_64 onto a fairly old Intel Core2Quad machine. Once I’d completed the install, I used the ssh rsync script to copy the production server over. Today I ran the final -m version.

When I finished, I checked /var/log/messages for errors. This is what was returned:

Jan 22 10:32:52 nethbox mysql.init: ERROR 1044 (42000) at line 22: Access denied for user 'root'@'localhost' to database 'information_schema' Jan 22 10:32:52 nethbox esmith::event[14531]: Loading information_schema.sql into mysql [FAILED] Jan 22 10:33:14 nethbox esmith::event[14531]: Action: /etc/e-smith/events/migration-import/S80nethserver-sogo-migrate FAILED: 255 [0.139551] Jan 22 10:33:14 nethbox esmith::event[14531]: Event: migration-import FAILED

The sofo import failure is simple enough to explain - sogo was not installed on the SME box. I’m not sure what could case the first failure and would be interested in knowing what I should do to overcome it.

I tried starting the server with the production SME taken off the network. It came up, but with problems. I had problems bringing up the second ethernet interface, though I was able to do so eventually. At that point, I was able to connect to the internet, but there seemed to be no local or internet DNS at all.

I can try a fresh install and migrate the data from the production server again, but I would be interested in knowing if there is anything else I need to check to get a working copy of the old SME server.

Paul.


(HF) #2

FYI 7.6 is available, did you upgrade after installing the ISO, or did you downloaded the ‘older’ version on purpose?


(paul_marwick) #3

:slight_smile: I downloaded the 7.5 version when it was current, installed shortly after that and haven’t had time to get back to it until the last couple of days. So I updated the 7.5 install.

Hopefully get back to have another look tomorrow. Looking through some of the files I brought back with me, it looks as though /etc/dnsmasq.conf was not modified to correct what had been the gateway and one of the DNS providers when the system was first installed. Maybe fixing that problem will fix the DNS issue…

Still uncertain about the “Access denied for user ‘root’@‘localhost’ to database ‘information_schema’” error.


(Markus Neuberger) #4

You should be able to enter mysql as root without password.

http://docs.nethserver.org/projects/nethserver-devel/en/latest/nethserver-mysql.html

Maybe you need to reset the password to the one in /var/lib/nethserver/secret/mysql or /root/.my.cnf:


(paul_marwick) #5

That may have some bearing - there is a /root/.my.cnf in the original SME installation. Maybe that is being used by the final migration? If so, I guess I could remove it before the 'screen rsync-migration -m '.

I have (potentially) 8 SME machines I want to migrate, some of which are going to be difficult to get to without disrupting the businesses in the process. So I need to make sure I can get it done with the minimum of errors… In some instances, migration from a backup will be the best option, but a couple of them are going to be combined with hardware upgrades, so the rsync option will be the best for them.

One thing that might be worth adding to the documentation is the fact that SME uses an old version of SSH, so /etc/ssh/sshd_conf on the Nethserver needs to be modified to allow use of deprecated ciphers for an SSH connection to be made. Took me a while to work out what ciphers to use…

Paul.


(Michael Kicks) #6

Well… I quite disagree…
If

  • hardware is going to be migrated to new server
  • old and new server can be stacked in same place (or nearby) for a while
  • a little longer downtime is a option

nothing is best than disconnect the server from public network, perform a full backup on a spare USB drive, install on new hardware the latest release and do the math for problem solving (at least at lan side)
This can lead to a quite long series of try and error steps, but also a full fallback option for any kind of issue, because the source server it’s intact and without modifications, and can be put online again without issue.


(Dan) #7

This sounds like a perfect argument for the rsync method, not against it.


(paul_marwick) #8

You seem to be missing the point.

Using the rsync method, the two machines can sit side by side and the migration done with NO downtime. When the migration is complete, shutdown the original sever and put the new one in its place. If there are problems, the old server can be brought back up pretty well instantly. For any business, minimising downtime is obviously desirable.

The only problem is if the migration does not involve replacing the server hardware - in that case, a migration using a backup is probably the only option.


(Michael Kicks) #9

Maybe I have the wrong perspective… Anyway, only my opinion, not disrespect for the path you choose.
Sorry for contaminate the thread.


(paul_marwick) #10

No problem. So far I’m failing to get a usable migration with either method :frowning:


(Markus Neuberger) #11

What’s not working? Which errors did you get?

Did you solve the mysql problem?

EDIT:

I didn’t notice that there’s a new thread: Unable to migrate from SME


(Alessio Fattorini) #12

Can we move on the new one @paul_marwick and close this?


(paul_marwick) #13

Don’t think that would be a problem - I started a new thread because I wasn’t sure if the problems I was seeing were related, but it looks as though they are, so this could be closed.