Problem with zoneminder installation

I installed nethserver on a virtualbox virtual machine in a Windows7 pc. As I need a video surveillance server, I followed your guide to install zoneminder. After some difficulties, I can start the service (command line: service zoneminder start), but I can’t access the address because I receive the following message:


404 - Not found


Can someone help me to solve this problem? I am a total newbie to linux/nethserver, so I really don’t know what to do …


NethServer Version: NethServer release 6.8 (Final)

Hi Katana,
Have you tried ? without the it-IT part

1 Like

That was the first thing I tried, as it was the address suggested in the guide. I obtained the following message:


404 - Language not found


I added the it-IT part because ilt was present in the dashboard address and I hoped it could solve the problem …

It may sound silly, but can you try with http instead of https?

I tried even this … obtaining the following:

Bad request

Bad request

Your browser sent a request that this server could not understand.
Reason: You're speaking plain HTTP to an SSL-enabled server port.
Instead use the HTTPS scheme to access this URL, please.

I see! just use https://ip-or-fqdn/zm without specifying the port :980

Just to test it I followed the guide but with some small changes:

Install zoneminder on NethServer 6.8 (64-bit)

yum -y install nethserver-mysql
yum -y install
yum -y install zoneminder
eorepo centos-{base,updates} nethserver-{base,updates} nethforge
mysql -e "create database zm"
mysql -e "grant all on zm.* to 'zmuser' identified by 'password'"    # replace 'password' with your choosen one
mysql < /usr/share/zoneminder/db/zm_create.sql
echo "/etc/zm.conf" > /etc/backup-config.d/zoneminder.include
sed -i s/zmpass/password/ /etc/zm.conf    # replace 'password' with the one you set before
service zoneminder start
service httpd restart

Have you re-tested it? Wow, does it still work ?

I tested the installation process on NS6.8 and it is working, thanks to @nethcman, but have no cameras to test zoneminder.

1 Like

Using the address without the port gets me the message “Forbidden You don’t have permission to access /zm on this server.”.

I don’t if this can help, but when I edited /etc/httpd/conf.d/zoneminder.conf I didn’t find the line “Deny from all”, but “Allow from all”. I deleted it the same …

You should have something like this in your /etc/httpd/conf.d/zoneminder.conf, which i think it’s the default you get after installing it with the commands dnutan wrote, i too installed one last week and it worked

also be sure to
service httpd restart
after changing anything in the zoneminder.conf file

# ZoneMinder Apache configuration file
# With SSLRequire and HTTPS auto redirect
# Modify this configuration to suit your requirements

# Auto Redirect HTTP requests to HTTPS
RewriteEngine On
RewriteCond %{HTTPS} !=on
RewriteRule ^/?(zm)(.*) https://%{SERVER_NAME}/$1$2 [R,L]

Alias /zm "/usr/share/zoneminder/www"
<Directory "/usr/share/zoneminder/www">
    Options -Indexes MultiViews FollowSymLinks
    AllowOverride All
    Order allow,deny
    Allow from all

ScriptAlias /cgi-bin/zm "/usr/libexec/zoneminder/cgi-bin"
<Directory "/usr/libexec/zoneminder/cgi-bin">
    AllowOverride All
    Options ExecCGI FollowSymLinks
    Order allow,deny
    Allow from all

I restored the line “Allow from all”, restarted httpd and zoneminder services and it worked!!

Summing up, I made two mistakes: I modified the /etc/httpd/conf.d/zoneminder.conf when it wasn’t necessary and I used the address with the port.

Maybe someone should update the guide?

Anyway, thank you all!!! :grinning::grinning::grinning:

1 Like

Thanks for the feedback and big thank you to @edi for his help!
Davide can you edit this? I have just wikified the post

Hi @katana

I love this support group :heart_eyes:

if you believe that the problem is solved, marks “solved” the answer that helped you. This helps anyone looking for the same problem and who responds to the support
thanks :grinning:

1 Like