Problem with NS8 Installation on(Top) of Debian 12

After the first failure several months ago, I tried again on an NS8 installation on a newly installed Debian 12 system. Unfortunately, there are fundamental problems this time too.

Basis system is a “proxmox VE 8.1.3” on Debian 12 (with NS8) as VM.

Debian 12 was installed by the installation medium
“Debian-12.4.0-AMD64-NINTINST.ISO”. The VM has two virtual disks (SCSI0, SCSI1), each for root file system and for the swap partition. The VM is currently assigned 4GB.

The installation was carried out using a graphic installer, but no graphic desktop environment was installed, only the SSH server and the standard system tools. After the start, the “sudo” package and according to the instructions “curl”. The following instructions were taken:
Installation — NS8 documentation

During the installation by the following command:

“curl | bash”

Finally, the following error appeared:

"Set kernel parameters:
/var/lib/nethserver/node/ line 39: sysctl: command not found.
Create the API server user:
/var/lib/nethserver/node/ line 43: useradd: command not found. "

I faced the output up to that, it would be reluctant to copy here due to the length.

I would now install the “userAdd” command and try again, but I consider the error message here to be Sinnvol to revise the dependencies in the installation script.

Greetings Yummiweb

It seems to be a problem with ambient variables.

The installation was carried out as “root” after the “SU” command (not sudo), which brought the problem described.

I have now registered as a root from the SU level by “login” and tried again, there were no mistakes until then.

I will now go back to the last snapshot again and try the installation again as a “real” root - just for verification.

Result: The installation runs clean when you are actually registered as a root, “SU” is not enough.

Now the question would be whether it would make sense to illustrate this part in the NS8 installation instructions. There is:

“Start the installation procedure as root:”

Or is this rather Debian mistake? The use of “su” should usually make the use of a “real” root registration unnecessary.

1 Like

Try an echo $PATH with su and su - on debian you will see it is not the same

But the real way to become root is ssh root@::1

What I have noticed in the meantime:

When setting up the first knot, the IP address area and the port are optionally queried or can be edited. The IP area was taken over, but its own port was not. My port should be on “60160”, but the previously proposed port was used.

Many thanks for your response. That is certainly correct. I actually did not consider the SSH registration as a root because it is usually not activated and should not be. Hence the detour via the “normal” user.

Installation of NS8 using a “su -” root shell worked for me on Debian 12 without issues.

TLDR “useless” suggestion: 4gb of ram is rather… not enough. It will work, but I personally suggest at least double (8gb).
Will reduce a lot swapping (using swap instead of ram) making the server (Ns8) really less sluggish.

Thanks for your advice, it must be enough for a test installation, it’s not the only one…