Problem with connection

webfilter
v7
proxy

(Federico Ballarini) #1

NethServer Version: 7
Module: Proxy/Firewall

I have a problem with the navigation… When I open a page (i think is a problem only with google and its services like analytics & co.) it remains in loading state and says “Creazione di una connessione protetta in corso” (Creating a secure connection in progress)…

Any solution?

Thanks,
Federico Ballarini


(Markus Neuberger) #2

Hello @federico.ballarini,

Maybe this could help you:

Feel free to provide logs like /var/log/squid/*…


(Federico Ballarini) #3

I have insert google domains in whitelist and also in “Domain without proxy” but it’s the same.
I opened only 80 and 443 ports… google use other ports?


(Markus Neuberger) #4

Do you have web content filtering active?
What about the logs in /var/log/squid?
Google usually just needs 80 and 443 AFAIK.


(Federico Ballarini) #5

Yes, I have web content filtering active but I have insert google domains into whitelist.
My log files are too long… how can I do?


(EnzoC) #6

in console do this

tail -f /var/log/ufdbguard/ufdbguardd.log

and in web browser refresh page www.google.com

if proxy block query, you find the locked category in this file


(Markus Neuberger) #7

If it is a log with time just take the time slice when the error occured. In other case reproduce the error and just take the last x lines of the log immediately. You can do it in the web UI in “Administration/Log Viewer” or via command line:

for getting the last 20 lines of /var/log/squid/access.log

…or do it with tail -f as @sharpec proposed


(Ralf Jeckel) #8

I would try to clear squid cache and browser cache first. Sometimes it helps. :wink:


(Federico Ballarini) #9

​Proxy doesn’t block query.​


(Federico Ballarini) #10

I will update you tomorrow.
Thanks to all.


(Federico Ballarini) #11

I think that the problem is proxy cache… now I have disabled it and all is working, but I check the situation tomorrow.


(Federico Ballarini) #12

I have also set google domains without proxy.


accounts.google.com
googledrive.com


docs.google.com
docs.google.com
c.docs.google.com
sheets.google.com
slides.google.com
gg.google.com
script.google.com
ssl.google-analytics.com
video.google.com
s.ytimg.com
apis.google.com
googleapis.com
googleusercontent.com
gstatic.com

client-channel.google.com
accounts.youtube.com
youtube.com

Now it’s working… if you know other google domains reply to this post.
Thanks.

Federico Ballarini


(EnzoC) #13

in fact I’m also having problems with google and the ssl transparent proxy in the last few days (never before). I’m forced to manually set up the proxy in Android connections


(Federico Ballarini) #14

Can you test my solution?
And give me a feedback. Thanks…
Also if you know other google domains post it here.
Thanks a lot.


(Marc) #15

https://www.google.com/supported_domains

Doesn’t seem a permanent/proper fix, IMO the problem should be find out.
Regards.


(Federico Ballarini) #16

In fact, the problem is in particular google but on other site https navigation is slowly than http navigation.
Someone can check this?
If someone of developers found this, can correct the bug?

Thanks… My network is composed by 250 computers, but on http and on google (that is excluded by proxy) it works very well and on https it is slow…


(Federico Ballarini) #17

I think that I solve the problem, enabling the testing repo.

yum --enablerepo=nethserver-testing update squid