Problem while answering email via iPhone7

sogo
v7
mail

(RoWiHei) #1

nethserver 7.6.1810
modul sogo 4.0.5

Hello friends,

there is a new problem with sogo. I searched in sogo.nu and nethserver community, but no proper solution found.
Short description:

The user06 usually works outside the home on construction sites. That’s why he syncs his iPhone7 with the nethserver7 / sogo4.
That works synonymous, BUT if he answers an email via iPhone, that goes awry, because the sender is automatically changed to user06@firma.lan

In the sogo webfrontend you can select the sender address: max.muster@firma.de.
On the iPhone it is unfortunately not possible to select this when replying to an email.

What can I do ?


(HF) #2

Did you try this?


(HF) #3

Sounds like a config error of the host/FQDN of some sort.


(Michael Kicks) #4

@rowihei how do the iPhone sync to the email server?
IMAP or ActiveSync?


(Gerald) #5

Basically, I use an Android smartphone.

E-mail (Aquamail) is integrated with IMAP:

  • Email reception - ok
  • Send eMail - ok
  • forward eMail - ok
  • Reply to eMail - ok

Calendar (ETAR) is integrated with CalDav:

  • Appointments are transmitted (synchronized)
  • both directions (SmartPhone <-> SOGo)

Directory:

  • both directions (SmartPhone <-> SOGo)

I use DAVx5 for syncronization.

Everything without problems :wink:


(Federico Ballarini) #6

Probably your first domain is firma.lan… if you can’t set identity on iPhone you can try to use this workaround (check to these posts):

Regards.


(RoWiHei) #7

Activesync


(RoWiHei) #8

Hallo !

this way is the right way - tested it with user06 > and now he can send answer to an incoming email via iPhone.
,"You have to modify the file /etc/postfix/canonical by adding at the end of the file this line:
user@yourdomain.ext user@ispdomain.ext

Replace user and yourdomain/ispdomain with real values.
Then launch command postmap /etc/postfix/canonical and check that it doesn’t return errors.
If yes restart postfix with systemctl restart postfix
…"
But next question : is it nessesary to write for each user00 … user99 a line into /etc/postfix/canonical … not very “admin friendly” ?
On nethserver6/sogo2.3.10 we had nearly the same config and NO problems with iPhones+Blackberries+Android-phones !
But thanks, now we see light at the end of tunnel ,


(Federico Ballarini) #9

With this work-around yes.


(RoWiHei) #10

Hallo LayLow,

think you’re right.
While installing the neth7 we called it mail.firma.lan as LDAP. Then we imported all mails from user00 … user20 via imapsync from old neth6.server
Then we created domain alias firma.de and email aliases max.muster@firma.de >> userxy.firma.lan for all users and pop3connector for each user, because we used a smarthost outsite.
We tested this before under proxmox KVM-server. In Sogo web interface all were ok:

  • Sending
  • getting and
  • answering to email

But we tested not the mobile devices, because under neth6 there was no problem.
Under admin page of neth7 we go to Management > Email addresses :
There we see:
User mailbox address | Custom mail quota | Custom spam retention | Forward addresses | Local network only …
user01@firma.lan 10 GB - - No

and so on
The real email address is only shown under [mail aliases] not under Forward address like it looks under neth6
But where is the config error ?


(HF) #11

I bet if @stephdl takes a look, a more constructive reply may follow.