Problem Proxy after Update

v7
proxy
webproxy

(Federico Ballarini) #1

NethServer Version: 7
Module: Proxy Web

There is another problem after proxy update (yesterday)… when I open the browser it remains blocked on “Download script proxy…”.
How can I solve this?

Thanks.


(Markus Neuberger) #2

Hi @federico.ballarini,

I have some questions:
Do you have this problem in all browsers or is it a specific one?
Does the problem remain if you restart squid?
Are there some errors in the logs? /var/log/messages, /var/log/squid/access.log


(Federico Ballarini) #3

The problem is IPS… when I disabled it Chrome works fine.
Why? What can be the category that block it?
With Firefox it’s all ok.

Thanks.


(Federico Ballarini) #4

It was INFO category that create a conflict.


(Joel Clendineng) #5

We have a thread close to the top of the first page discussing this, if you would, put this info there, it may help us with the issue. Slow web proxy operation


(Joel Clendineng) #6

INFO is mainly bad headers, and sites looking for exploits. You should leave it on, but we need to figure out why its not working. I have INFO (well I have everything almost) as BLOCKED and no issues so far here, can you tell us what website you were trying to go to? Go to https://www.google.com and report back with INFO enabled. Ill download chrome here and test, maybe a chrome issue with the way it handles proxy.


(Federico Ballarini) #7

With INFO enabled.

On Firefox: all ok.
On Chrome: when I open a new window of Chrome (indifferently to the page that I’m trying to open) it takes about 15 seconds to load the page… after that all works fine.


(Markus Neuberger) #8

Can’t reproduce it, all sites are working fast:

  • IPS Info is set to block
  • Proxy SSL transparent mode
  • Chrome 62.0.3202.62 (64 bit) on Windows 7

Do you use Windows clients? On Windows Firefox can have its own proxy settings, whereas Chrome just takes the system settings which are also used by Internet Explorer. Maybe change settings here…


(Federico Ballarini) #9

I don’t know why it’s not working…
The only different is that my PCs are Windows 10…


(Markus Neuberger) #10

Tried it now with Windows 10, fresh installed Google Chrome, and it works.
On my Windows client Nethserver is default gateway and DNS Server.
Windows(Chrome) proxy settings:


(Federico Ballarini) #11

It’s the same configuration…


(Markus Neuberger) #12

My package versions(fully updated Nethserver 7.4):
nethserver-squid 1.7.0-1.ns7
squid.x86_64 7:3.5.20-999
nethserver-suricata 1.1.0-1.ns7
suricata.x86_64 3.2.3-1.el7


(Federico Ballarini) #13

Versione sistema: NethServer release 7.4.1708 (Final)
Versione kernel: 3.10.0-693.5.2.el7.x86_64
nethserver-squid 1.7.0 1.ns7
squid 3.5.20 999.ns7
nethserver-suricata 1.1.0 1.ns7
suricata 3.2.4 1.el7


(Federico Ballarini) #14

I have updated now suricata version form 3.2.3 to 3.2.4 and seems it works.


(Federico Ballarini) #15

False alarm… it isn’t working properly…
I don’t know what can be the problem…


(Federico Ballarini) #16

I solve (a few days ago) with enabling repository of test.