Problem during update - Package: samba-winbind-clients-3.6.23-33.el6.i686

I have a problem during a update.
When I run yum update, after the check, I have this return:

--> Running transaction check
---> Package ncurses-libs.i686 0:5.7-4.20090207.el6 will be installed
---> Package samba-winbind-clients.i686 0:3.6.23-33.el6 will be installed
--> Processing Dependency: samba-winbind = 3.6.23-33.el6 for package: samba-winbind-clients-3.6.23-33.el6.i686
--> Finished Dependency Resolution
Error: Package: samba-winbind-clients-3.6.23-33.el6.i686 (base)
           Requires: samba-winbind = 3.6.23-33.el6
           Removing: samba-winbind-3.6.23-25.el6_7.x86_64 (@centos-updates)
               samba-winbind = 3.6.23-25.el6_7
           Updated By: samba-winbind-3.6.23-35.el6_8.x86_64 (nethserver-updates)
               samba-winbind = 3.6.23-35.el6_8
           Available: samba-winbind-3.6.23-20.el6.x86_64 (centos-base)
               samba-winbind = 3.6.23-20.el6
           Available: samba-winbind-3.6.23-21.el6_7.x86_64 (centos-updates)
               samba-winbind = 3.6.23-21.el6_7
           Available: samba-winbind-3.6.23-24.el6_7.x86_64 (centos-updates)
               samba-winbind = 3.6.23-24.el6_7
           Available: samba-winbind-3.6.23-30.el6_7.x86_64 (centos-updates)
               samba-winbind = 3.6.23-30.el6_7
           Available: samba-winbind-3.6.23-33.el6.x86_64 (base)
               samba-winbind = 3.6.23-33.el6
           Available: samba4-winbind-4.0.0-66.el6_6.rc4.x86_64 (centos-base)
               samba-winbind = 4.0.0-66.el6_6.rc4
           Available: samba4-winbind-4.0.0-67.el6_7.rc4.x86_64 (centos-updates)
               samba-winbind = 4.0.0-67.el6_7.rc4
           Available: samba4-winbind-4.0.0-68.el6_7.rc4.x86_64 (centos-updates)
               samba-winbind = 4.0.0-68.el6_7.rc4
           Available: samba4-winbind-4.2.10-6.el6_7.x86_64 (base)
               samba-winbind = 4.2.10-6.el6_7
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Before, I was make a downgrade of SAMBA for compatibility from Nethserver with machines with W7 and WXp. Now I have all computers with w10.
I think this problem happen because I have done this downgrade, and now I can`t do the update (and install new packages that I need)

I already do a cache clean in Yum and use the --skip-broken option.

Someone can help?

Nethserver 6.7

Hi @EduardoGCorrea,

Try to update the single package as first step. Then update everything - 6.7? veeery old :wink:

Let me know how it goes!

I actuaty try do a single package update. Same error.

Some informations about the server:

[root@sam0 /]# cat /etc/yum/vars/distroversion


[root@sam0 /]# cat /var/cache/yum/x86_64/6/centos-base/mirrorlist.txt

I can´t update to centos 6.8 too… I´m stuck!!!

Hmm… Guys…

I remove samba and samba-winbind

Do a full update

And install this packages again (with all of the dependencies)

Works fine (for now), but I am afraid of reboot the server (HAHAHAH). I Have a full backup of this server, but… It will be a big mess if I´ll have to reinstall from begin.


Hi @EduardoGCorrea,
you restart the server? it worked?:slight_smile:

If everything works please marks “solved” in the response that helped you. This will help those who have the same problem to find the solution. :+1:

1 Like

Eduoard can you please give us a feedback?

1 Like