Problem accessing the webUI from VPN and win7


From work; with Win7 pc, OpenVpn to pfsense at home (vm machine in NS).
i can access NS trought SSH, NS on port 80 and 980 (no https), but if i try to access the webgui at https://NSIP:980
the page won’t load:

Same situation (VPN from work) with my android phone, i can access the webui without problem…
i’m not sure what is the problem…


EDIT: also http://NSIP:8000 (webvirtmgr) can’t be accesed from win7, no problem from android.
the page seem to not completly load:

If it’s only with Firefox, try it disabling the add-ons.
If it does not work, press CTRL + SHIFT + Q to bring up developer tools and look for network requests errors.

Is it working with other web browsers?

also with other browser doesn’t work… (chrome, chromium, explorer)


Check your AV settings (firewall, …) on win7 machine.

Kaspesky (and windows firewall) :tired_face: diabled but the problem perist :frowning:

Edit: also trying to disable the proxy on pfsense doesn’t solve the problem :neutral_face:

Maybe it’s related to the MTU size.
From Windows you can try to discover the right MTU packet size with:

ping -l 1500 -f youraddress

decreasing 1500 until the ping succeeds.

i can ping it and connect to ssh without problem… :frowning:

Please share tracert from windows mashine!


Try to restart httpd-admin service. Maybe some half open connection and please share tracaroutre from NS to your Win PC.

from ns i can’t rach the pc…it is in a client to site vpn config…rebooting NS doesn’t solve the problem :frowning:

EDIT after some hours charging the page… i can see the login page…waiting other 2 hours to login?..

i think that’s a windows pc problem… no problem from phone…

Maybe you are redirected to the hostname instead of the IP?

But in that case also on the phone shuldn’t work right? Or is just a misconfig in win7? :worried:

This makes absolutely no sense.
Now it work… nothing has changed…

EDIT: the only change i have made in these days is to disable “Hardware Checksum Offloading” on my pfsense (virtual machine on NS) but i don’t know if this can cause that problem.


I dont want to ressurect an old thread but i had a similar issue.
The setup is different, here Nethserver runs as a VM and doing the VPN server role.
I could not connect to any VM or the VM HOST, i was able to connect fine to Nethserver VM.
I ended up trying pfsense which had the same issue.
I read up on the virtio settings and it has problems with some hardware and disabling “Hardware Checksum Offloading” fixes the problem.
So i think i can revert back to Nethserver VPN also, but my question is how to turn off Hardware Checksum Offloading on Nethserver ?

You may check the ethtool -K manual for offloading parameters.