Precautions when using systems within NethServer

Previously I had been excited to see PacketFence, but when the facility had to make several configurations until they reached the latest versions much faster for installation and use.

Now there is the problem that PacketFence repositories, there is more updated than NethServer packages, and generate conflicts in the medium term.

Doing a test installation in NethServer netdata occurred this:

[root@firewall-hardsoft ~]# yum install zlib-devel libuuid-devel libmnl-devel gcc make git autoconf autogen automake pkgconfig
Loaded plugins: changelog, fastestmirror, nethserver_events, presto
Setting up Install Process
Loading mirror speeds from cached hostfile

  • centos-base: mirror.us.leaseweb.net
  • centos-updates: mirror.us.leaseweb.net
  • nethforge: mirror1.nethserver.org
  • nethserver-base: mirror1.nethserver.org
  • nethserver-updates: mirror1.nethserver.org
    centos-base | 3.7 kB 00:00
    centos-updates | 3.4 kB 00:00
    home_kot1grun | 1.2 kB 00:00
    nethforge | 3.6 kB 00:00
    nethforge/primary_db | 14 kB 00:00
    nethserver-base | 3.7 kB 00:00
    nethserver-base/primary_db | 477 kB 00:01
    nethserver-updates | 4.0 kB 00:00
    Package zlib-devel-1.2.3-29.el6.x86_64 already installed and latest version
    Package 1:make-3.81-23.el6.x86_64 already installed and latest version
    No package autogen available.
    Package 1:pkgconfig-0.23-9.1.el6.x86_64 already installed and latest version
    Resolving Dependencies
    –> Running transaction check
    —> Package autoconf.noarch 0:2.63-5.1.el6 will be installed
    —> Package automake.noarch 0:1.11.1-4.el6 will be installed
    —> Package gcc.x86_64 0:4.4.7-17.el6 will be installed
    –> Processing Dependency: cpp = 4.4.7-17.el6 for package: gcc-4.4.7-17.el6.x86_64
    –> Processing Dependency: glibc-devel >= 2.2.90-12 for package: gcc-4.4.7-17.el6.x86_64
    –> Processing Dependency: cloog-ppl >= 0.15 for package: gcc-4.4.7-17.el6.x86_64
    —> Package git.x86_64 0:1.7.1-4.el6_7.1 will be installed
    –> Processing Dependency: perl-Git = 1.7.1-4.el6_7.1 for package: git-1.7.1-4.el6_7.1.x86_64
    –> Processing Dependency: perl(Git) for package: git-1.7.1-4.el6_7.1.x86_64
    —> Package libmnl-devel.x86_64 0:1.0.2-3.el6 will be installed
    –> Processing Dependency: libmnl(x86-64) = 1.0.2-3.el6 for package: libmnl-devel-1.0.2-3.el6.x86_64
    —> Package libuuid-devel.x86_64 0:2.17.2-12.24.el6 will be installed
    –> Running transaction check
    —> Package cloog-ppl.x86_64 0:0.15.7-1.2.el6 will be installed
    –> Processing Dependency: libppl_c.so.2()(64bit) for package: cloog-ppl-0.15.7-1.2.el6.x86_64
    –> Processing Dependency: libppl.so.7()(64bit) for package: cloog-ppl-0.15.7-1.2.el6.x86_64
    —> Package cpp.x86_64 0:4.4.7-17.el6 will be installed
    –> Processing Dependency: libmpfr.so.1()(64bit) for package: cpp-4.4.7-17.el6.x86_64
    —> Package glibc-devel.x86_64 0:2.12-1.192.el6 will be installed
    –> Processing Dependency: glibc-headers = 2.12-1.192.el6 for package: glibc-devel-2.12-1.192.el6.x86_64
    –> Processing Dependency: glibc-headers for package: glibc-devel-2.12-1.192.el6.x86_64
    —> Package libmnl-devel.x86_64 0:1.0.2-3.el6 will be installed
    –> Processing Dependency: libmnl(x86-64) = 1.0.2-3.el6 for package: libmnl-devel-1.0.2-3.el6.x86_64
    —> Package perl-Git.noarch 0:1.7.1-4.el6_7.1 will be installed
    –> Running transaction check
    —> Package glibc-headers.x86_64 0:2.12-1.192.el6 will be installed
    –> Processing Dependency: kernel-headers >= 2.2.1 for package: glibc-headers-2.12-1.192.el6.x86_64
    –> Processing Dependency: kernel-headers for package: glibc-headers-2.12-1.192.el6.x86_64
    —> Package libmnl-devel.x86_64 0:1.0.2-3.el6 will be installed
    –> Processing Dependency: libmnl(x86-64) = 1.0.2-3.el6 for package: libmnl-devel-1.0.2-3.el6.x86_64
    —> Package mpfr.x86_64 0:2.4.1-6.el6 will be installed
    —> Package ppl.x86_64 0:0.10.2-11.el6 will be installed
    –> Running transaction check
    —> Package kernel-headers.x86_64 0:2.6.32-642.1.1.el6 will be installed
    —> Package libmnl-devel.x86_64 0:1.0.2-3.el6 will be installed
    –> Processing Dependency: libmnl(x86-64) = 1.0.2-3.el6 for package: libmnl-devel-1.0.2-3.el6.x86_64
    –> Finished Dependency Resolution
    Error: Package: libmnl-devel-1.0.2-3.el6.x86_64 (centos-base)
    Requires: libmnl(x86-64) = 1.0.2-3.el6
    Installed: libmnl-1.0.3-4.centos6.x86_64 (@packetfence)
    libmnl(x86-64) = 1.0.3-4.centos6
    Available: libmnl-1.0.2-3.el6.x86_64 (centos-base)
    libmnl(x86-64) = 1.0.2-3.el6
    You could try using --skip-broken to work around the problem
    You could try running: rpm -Va --nofiles --nodigest

If I want to remove the package repository PacketFecnce happens that would eliminate almost all packages NethServer

[root@firewall-hardsoft ~]# yum remove libmnl-1.0.3-4.centos6.x86_64

Dependencies Resolved

================================================================================
Package Arch Version Repository Size

Removing:
libmnl x86_64 1.0.3-4.centos6 @packetfence 46 k
Removing for dependencies:
conntrack-tools x86_64 1.4.1-1.centos6 @packetfence 390 k
daq x86_64 2.0.2-1 @nethserver-base 646 k
ipset x86_64 6.11-4.el6 @extras 166 k
libnetfilter_conntrack x86_64 1.0.3-1.centos6 @packetfence 122 k
libnetfilter_cthelper x86_64 1.0.0-3.centos6 @packetfence 32 k
libnetfilter_cttimeout x86_64 1.0.0-1.centos6 @packetfence 35 k
libnetfilter_queue x86_64 1.0.2-1.el6 @nethserver-base 41 k
nethserver-firewall-base noarch 2.10.6-1.ns6 @nethserver-base 114 k
nethserver-firewall-base-ui noarch 2.10.6-1.ns6 @nethserver-base 238 k
nethserver-ipsec noarch 1.1.7-1.ns6 @nethserver-base 86 k
nethserver-lightsquid noarch 1.0.5-1.ns6 @nethserver-base 37 k
nethserver-openvpn noarch 1.3.1-1.ns6 @nethserver-updates 78 k
nethserver-release noarch 6.8-1.ns6 @nethserver-base 42 k
nethserver-snort noarch 1.0.3-1.ns6 @nethserver-base 48 k
nethserver-squid noarch 1.3.11-1.ns6 @nethserver-updates 92 k
nethserver-squidclamav noarch 1.2.0-1.ns6 @nethserver-updates 41 k
nethserver-squidguard noarch 1.4.3-1.ns6 @nethserver-base 155 k
snort x86_64 1:2.9.7.2-2 @nethserver-base 18 M

Transaction Summary

Remove 19 Package(s)

If continued, would fail the entire installation of NethServer.

It is advisable to test virtual machines and not on NethServer production.

P.D: PacketFence is best used in other Hardware, outside NethServer.

Regards

1 Like