Postgresql on Nethserver


(Ralph) #1

Hello,

I installed postgresql-9.4 and phpPgAdmin from the epel repo, and both work fine. But the services list in the web gui always states that postgres is stopped. Presumably there is a mismatch between the nethserver-postgresql package which refers to the old version 8.4 and the actually installed version 9.4.
Can anybody tell where in the system the status information of services is taken from or what has to be adjusted so that postgesql is correctly shown as enabled?

Thanks.


PostgreSQL on NS7
(Artem Fedai) #2

so all is prety simple :
Web UI run this /usr/libexec/nethserver/read-service-status and watch config show for service instance like
xinetd=service
status=enabled
and run service xinetd status
you could simply modify db configuration for postgresql


(Ralph) #3

It’s not that simple. “config show” reports
postgresql=service
TCPPort=5432
access=none
status=enabled
"service postgresql status" gives me "unrecognized service"
But “service postgresql-9.4 status” states “enabled”.
Where is the db configuration to be modified and in which way?


(Giacomo Sanchietti) #4

You can create a service in the config db named as the init.d script: postgresql-9.4


(Artem Fedai) #5

config set postgresql-9.4 service TCPPorts 5432 access none status enabled


(Ralph) #6

Yeah, that did the trick. Thanks!


(Alessio Fattorini) #7

Could you add all commands here? It can be helpful for others