Possible Bug with nethserver-cockpit Connectors

Nethserver cockpit includes an feature to check credentials for POP3 connector in my case I’m using this plian pop 3 and the chek fails every time even though it’s obviously working as forwarded mail is being delivered to my inbox.

1 Like

Thank you for reporting, I can’t understand the problem. Could you please post a list of steps to reproduce?

Thanks!

1 Like

Hi,

Yes no problem in Nethserver-cockpit under Email application, I clicked connectors, (I already have several I’ve setup through nethgui). I attempted to create a new connector entered all details and the last step was for the system to automatically check login credentials.

This failed for my new connector which in itself I wasn’t too worried about but after a lot of double checking I decided there were no issues with the new credentials. I then opened up one of my already existing connectors for editing and ran the check on that and that failed too. ( However the existing connector is already in use and working.)

I’ve since run into exactly the same issue creating a new backup, credential check fails on both new and existing backups but the existing backups already work.

1 Like

I can confirm this bug, the check in the new server manager fails with working credentials, see also Pop3 connector cant check the connection to the mailserver

The “Check credentials” button never worked for me so you can’t save a new connector because the “Save” button is greyed out.

grafik

New issue: https://github.com/NethServer/dev/issues/5873

The fix is read to be tested:

yum --enablerepo=nethserver-testing update nethserver-mail-*

/cc @strauch

1 Like

Hi,
Thanks for the quick fix unfortunately doesn’t seem to work for me. I now have a mix of usernames on this system, some that contain an @ and some that don’t.

The ones that have an @ still do not work but the ones without do, I also can’t seem to show the password anymore.

Incidentally not sure if it’s expected behaviour but runnign the yum --enablerepo command through ssh didn’t seem to work* but running it through cockpit did?

(* Didn’t find any mail packages that were marked to update)

If it helps my external mail has an @ but internal does not and I’m connecting via POP3 rather POP3s imap etc.

There was a typo on my command, sorry for the inconvenient. :frowning:
The correct command should be:

yum --enablerepo=nethserver-testing update nethserver-mail-*

To make sure that the correct version is installed, type the following command:

rpm -q --changelog nethserver-mail-common

Output should be similar to:

* Tue Oct 22 2019 Giacomo Sanchietti <giacomo.sanchietti@nethesis.it> - e148d3e
- api mailbox: avoid log noise (#156) (HEAD, origin/master, origin/HEAD, master)
  NethServer/dev#5878

* Tue Oct 22 2019 Giacomo Sanchietti <giacomo.sanchietti@nethesis.it> - 00783a9
- api connectors: correctly handle username with '@' (#157)
 curl: (6) Could not resolve host:
  domain.org:mypass@192.168.5.1.1; Unknown error
   Also protect the input from shell injection.
   NethServer/dev#5873

* Mon Oct 21 2019 Andrea Leardini <andre8244@gmail.com> - 4c21b35
- ui. disabled UI controls while following logs (#154)
  - Invoke system-logs API as superuser
  - Disabled log combobox while following logs in Cockpit Logs page
   NethServer/dev#5866

Hi Sorry but just tried the version check and I do appear to have your latest version (#157)
but the check still fails for me. I have about 11 connectors set up and tried about 4 to confirm results were the same on all. I’m using firefox on windows will try another browser shortly to confirm results are the same.

Just tried it in edge and still had the same result also tried creating a new connector rather than just editing an existing one, (still the same).

Password preview works on creation but not editing btw.

Thank you @jcp2mill, we will investigate further!

@jcp2mill I tried to reproduce your issue with the testing package.

It seems the bug is fixed. However the 2 seconds timeout could be too low for slow/busy servers. Do you think the connection to your POP3 server takes longer?

Sorry to pop in (erm… pun intended), but indeed POP3 which is an old protocol and could potentially reach slow servers, needs a bigger time out I think.
Why not be configurable?

1 Like

Could be a nice idea for some edge cases.

The “Check” button actually runs curl, like other UI forms. We can pass a global configuration file to curl, every time we invoke it to check remote credentials. The --config option should be good for that.

Could well be the case with our external server I don’t have anything setup I can easily compare against at the moment, ( it’s an old server hosted by iomart and is a pretty basic setup tbh).

We’ll probably switch in the not too distant future but for now I have to do the best I can with what I’ve got and I’m a big fan of the cockpit interface so was hoping to do it all the admin through there.

1 Like

Fix released with improved timeout (10 seconds).

HI All,

Sorry for the long delay between updates I’ve been off sick after an operation.

Unfortunately this still doesn’t work for me even with the new 10 second timeout.

It’s not a game change for me as long as it can still use nethgui to set up the connectors just a bit of a pain, (making testing a bit more involved)

@giacomo did you remember how the timeout can be tuned into an email client?