Port 443 not forwarded

NethServer Version: 7.8.2003 (final)
I have a webserver in the LAN and I want to publish it to the internet. I created the port forward rules for port 80 and port 443. Port 80 is working. Port 443 is not open, times out. I tested port 443 on the destination machine from the LAN and is open. What can be the problem?


Can we get a better idea of your network layout and how you have NS configured within your network.


Both in LAN and from the internet the hostname is resolved in the same IP. I have the same behavior even if I use the the IP address.

I have new details here which might help. On the Nethserver I have a WAN failover configured. The main line is static IP the backup line is PPPoE. The port forward for 443 works on the backup internet line(PPPoE), but not for the primary connection.

Interesting for us is how your interfaces are configured. A green one for internal network and a red one for Internet-Access? What is about your vhost config? Did you configure it to listen on port 443?


Sorry didn’t read this before.
Is there a router before nethserver? Perhaps it doesn’t route port 443. Have a look at the router configuration.

Nethserver is the only router. Actually I had a similar port forwarding problem with Nethserver and I was not able to fix it, I had to change the port. But now I don’t have this possibility.

Some other ideas?

Why do you need a protforwarding? IIUC your NS is router and webserver in once.
If httpd has access to red interface port 80 and 443 are normally open to the internet.

Is your modem (static connection) configured as passthrough or has ist it’s own firewall?

I want to publish a webserver behind the Nethserver router.
443 port is not filtered by the provider. If I disable the port forwarding rule for 443, the nethserver interface will load. If I enable the port forwarding rule I will get time out, but only with the primary internet connection. On the backup internet connection I’m able to access the webserver behind the Nethserver.
The webserver behind the Nethserver has a firewall but I made tests and it doesn’t look like it is the cause of the problem. I also disabled it and the problem persists.

@adv have you tried using the reverse proxy?

1 Like

I never setup a reverse proxy. So I don’t know if I can do it or it will solve the problem.

So I did not unsterstand correctly and it shows, how importand it is, to discribe the network layout detailed. :wink:

1 Like

Built in and it re-directs 80/443 traffic to a define host you declare. I use a reverse proxy for instance to reach nextcloud.mydomain.com, mail.mydomian.com and my freenas.mydomain.com each on different hosts.