POP3Connector socket error ([Errno 110] Connection timed out)

NethServer Version: release 7.6.1810 (final)
Module: POP3Connector

After running the last update, I can’t download mail with the POP3Connector
The error I find in the log is as follows:

mail getmail: email@mailserver.ext.cfg: socket error ([Errno 110] Connection timed out)

I get the same answer by starting the command / usr / bin / getmail -vvvv --getmaildir / var / lib / getmail / --rcfile /var/lib/getmail/email@mailserver.ext.cfg

I tried to:

  • uninstall the module and reinstall it from the web interface on port 980
  • manually reinstall the module and dependencies
  • search Google for information on the error and its solution

Does anyone else have this error?
Does anyone know how to fix it?

Thank you so much for the precious help you will give me.

Could this be CentOS7.7 related?
@giacomo @davidep

There’s no information to say it. The request is about ns 7.6

First of all, thanks for asking the NethServer community!

Please provide the RPM versions installed on your system. They are available in the software center page.

The connection could be blocked by the remote server or something between.

1 Like

Thank you all for your interest.
The problem has been solved.
The network manager had blocked the pop3 server ip by mistake.
Once the firewall rule has been eliminated, everything has started working again.

1 Like