POP3 Connection refused


(Enzo P) #1

Hello,
It is a few days that I can not retrieve messages from my provider for one of my two domains.
This is the error that I find in the log fetchmail:

Dec 21 11:50:02 [err] connection to pop3.xxxxxx.it:pop3 [192.168.1.250/110] failed: Connection refused.
Dec 21 11:50:02 [err] POP3 connection to pop3.xxxxxx.it failed: Connection refused
Dec 21 11:50:02 [info] Query status = 2 (SOCKET)

A while ago I had the same thing happened, I had solved restoring from backup to a few days before, but now does not work either so.

I tried to install a temporary version of Nethserver and everything works (so it is not a fault of my provider).

What can I do?

Thank you in advance

Enzo


Can not receive emails from outside
(Giacomo Sanchietti) #2

Your ISP server is not responding, maybe a temporary problem.

If you want, you can test the connection using netcat: http://webmechanic.blogspot.it/2006/11/using-gnu-netcat-to-access-your-pop3.html


(Enzo P) #3

Thanks Giacomo,

if I try netcat with nc -v -v pop3.xxxxxx.it 110, from Nethserver I get

nc: connect to pop3.xxxxxx.it port 110 (tcp) failed: Connection refused

but if I try from temporary installation of Nethserver everything works fine and I get

Connection to pop3.xxxxx.it 110 port [tcp/pop3] succeeded!

Something broken in fetchmail?


(Giacomo Sanchietti) #4

It’s non fetchmail related.

Check your firewall configuration from the “Firewall rules” page. Also you can check /var/log/firewall.log


(Enzo P) #5

I don’t think is firewall related, because it isn’t active, furthermore the other domain with very similar parameters working properly.
Look here

Dec 22 10:24:40 [info] 21 messages (21 seen) for aaaaaaaa@yyyyyyyyy.eu at pop3.yyyyyyyyy.eu (136345 octets).

Dec 22 10:24:40 [err] connection to pop3.xxxxxxx.it:pop3 [192.168.1.250/110] failed: Connection refused.
Dec 22 10:24:40 [err] POP3 connection to pop3.xxxxxxx.it failed: Connection refused
Dec 22 10:24:40 [info] Query status=2 (SOCKET)

and

[root@NethServer ~]# nc -v -v pop3.yyyyyy.eu 110 Connection to pop3.yyyyyy.eu 110 port [tcp/pop3] succeeded!
+OK Dovecot ready. ecc.
quit
+OK Logging out

[root@NethServer ~]# nc -v -v pop3.xxxxxx.it 110 nc: connect to pop3.xxxxxx.it port 110 (tcp) failed: Connection refused


(Stefano) #6

it’s likely a policy on target machine… ISP don’t like you poll their servers too often

in the past, when fetchmail was the only way to catch email form ISP, some users wanted to poll external server every minute… and that’s bad


(Enzo P) #7

I try to poll every 10 minutes (from 5).
I will keep you informed


(Filippo Carletti) #8

Sorry if it may seem obvious: please, ask your ISP.


(Enzo P) #9

I’ve already asked, and they say that on their part is all right


(Artem Fedai) #10

@Enzo
make traceroute to this host and share it pls


(Stefano) #11

well, obviously on their side is all ok :smile:

they can use some bandwidth policies to save resources, so if your client gets a “connection refused” error, it’s not an issue on their side…


(Enzo P) #12

THANK YOU Artem,
you pointed me in the right direction.
A traceroute to my pop3 address receiving the response only from my local IP address (192.168.1.250).
So I checked the /etc/host file, and I found:
192.168.1.250 NethServer.xxxxxx.it NethServer smtp.xxxxxx.it imap.xxxxxx.it pop.xxxxxx.it pop3.xxxxxx.it
After removing the last two entries everything works fine.
But the file header say:

================= DO NOT MODIFY THIS FILE =================

Manual changes will be lost when this file is regenerated.

So, what do I do now?


(Filippo Carletti) #13

Go to server-manager, DNS and delete the pop3 host (anr/or any relevant host).


(Enzo P) #14

Thanks Filippo,
I had already looked at, but as you can see was, and it is, empty


(Filippo Carletti) #15

Please, look into the “Alias server” tab.


(Enzo P) #16

empty too


(Artem Fedai) #17

Dears,

config show postfix
postfix=service
    **MxRecordStatus=enabled**


cat /etc/e-smith/templates/etc/hosts/01mx_record
.{
    #
    # 01mx_record -- push smtp, imap, pop, pop3 aliases
    #

    # Add DNS aliases only if acting as resolver:
    use NethServer::Service;
    my $s = new NethServer::Service('dnsmasq');
    if( $s->is_owned() && $s->is_enabled() && $postfix{MxRecordStatus} eq 'enabled')  {
        push @hostnames, map { join('.', $_, $DomainName) } qw(smtp imap pop pop3);
    }
    '';
}

Run :

db configuration setprop postfix MxRecordStatus disabled
signal-event nethserver-mail-common-update

I can no longer send email
(Artem Fedai) #18

Hi @giacomo @filippo_carletti ,

Why do we need this records in /etc/hosts , maybe it is better to let the people choose these records in DNS Section ?


(Enzo P) #19

Thanks Artem,
after your fix my hosts file it’s correct.
Thanks again and best wishes for the New Year to everyone.

Ciao
Enzo