Please help me :( I can't install new software

Hello, I’ve been wanting to solve this error for more than 3 hours, pls if someone know how to solve it reply pls is for a school project.
MicrosoftTeams-image (19)


welcome to NethServer Community.

What do you want to achieve?

Did you already paste the command to a terminal?

Please have a look at /var/log/messages to maybe get more error details.

1 Like

Hello thanks for the welcome, yes I tried already and it gives me this

Sorry if I don’t get what it tells me, I’m new on this world.

Can you connect outside?


Maybe clean yum cache and installing manually helps:

yum clean all

yum -y install nethserver-httpd-virtualhosts


Here’s a workaround for similar error:

1 Like

Ok, nope I couldn’t ping to, then I type yum clean all, that went well, and then yum-y install nethserver-httpd-virtualhosts and it gave me this, it seemd like it cannot find a valid baseur1 for repo: ce-base/7/x86_64

Please try


to check if your WAN connection is ok.

Your DNS servers seem to be wrong or there are network issues (wrong gateway etc.)

Let’s check your config with

db networks show

It was just a guess…there could be other things wrong…


The gateway is not in the same network as the WAN IP. Is it a config mismatch?

Please explain your network. Is there another router in your network? Do you really need two interfaces?

1 Like

Maybe is a config mismatch sorry, is my first time using this, I just copied what my teacher had.

1 Like

Your teacher teaches you NethServer? That’s pretty cool.

Can you connect to internet with a laptop or another device? This way you can check out the connection settings (IP, subnet, gateway) and use it within NethServer.

You may also check out the documentation for more information.

1 Like

Yes sir he give us OS classes and we have to mount our server to another project of web applications.
Yes I can connect to internet with other device, how I had to check the connections settings?

It depends on the OS you are using on the other device:


You need to run cmd to enter following command.

ipconfig /all

This shows you the IP, the subnet mask and the gateway the network device is using.


To show IP addresses:

ip a

To show routes(gateway):

ip r

Ok I got them all, should I write the default gateway showed?

Yes, enter it in the network settings.
You may need to use another IP so add 1 to the last number like if your other device has use

Ok sir, just one point, I’m using this on VMware in case anything should bee different
VMWare workstation

VMWare workstation or ESXI?


You may need to setup the VM network to bridged instead of NAT.

I think easiest setup would be to just have one bridged green network interface.
There you enter your IP+1, subnetmask and gateway.

Amm I already have that, I can show you my specifications if you want. Sorry for asking too much but thank you a lot.

Sorry haha it tells that I have to wait 24 hours to make more replys
I’ll keep writing under this.
In the meanwhile I’ll try with the default gateaway of my ip.
Sir I typed my default gateway on the WAN network, and tried ping and it actually ping this time
THANKS A LOT, well it seems like it finally worked, if later on I have more question i’ll be typing again thanks for a lot!