Phpvirtualbox error templates

phpvirtualbox
v7

(Jose Manuel Insausti) #1

NethServer Version: NethServer release 7.6.1810
Module: phpvirtualbox

NethServer release 7.6.1810

i have this error when i run “signal-event phpvirtualbox-update”

Can’t open directory /etc/e-smith/events/phpvirtualbox-update

the installation in principle has not given any problems


(Dan) #2

I’m going to guess that it should instead be signal-event nethserver-phpvirtualbox-update.


(Jose Manuel Insausti) #3

I’m following the documentation.

but I think the solution is …

signal-event nethserver-virtualbox-5.2-phpvirtualbox-update


(Marc) #4

You’re right, the documentation is wrong. Here’s the source code making reference to the version ($digits):



(Jose Manuel Insausti) #5

Now I have another problem.

when I access the control panel http: //midominio.lan/phpvirtualbox

I have the following error
Exception Object
(
[message:protected] => Error logging in to vboxwebsrv.
[string:Exception:private] =>
[code:protected] => 64
[file:protected] => /usr/share/phpvirtualbox/endpoints/api.php
[line:protected] => 134
[trace:Exception:private] => Array
(
)

[previous:Exception:private] => 

)


(Stéphane de Labrusse) #6

what is the output of

/sbin/vboxconfig

did you before do a full upgrade then followed by a reboot ?

what is the output of

rpm -qa | grep gcc


(Stéphane de Labrusse) #7

sorry the doc is wrong, you need to do

signal-event phpvirtualbox-save

just for your information, you can play with autocompletion and event, when you want find a specific one

do signal-event phpvirtual then press the tab key


(Jose Manuel Insausti) #9

/sbin/vboxconfig

[root@bi phpvirtualbox]# /sbin/vboxconfig
vboxdrv.sh: Stopping VirtualBox services.
vboxdrv.sh: Starting VirtualBox services.
vboxdrv.sh: Building VirtualBox kernel modules.

did you before do a full upgrade then followed by a reboot ?

Yes

[root@bi phpvirtualbox]# rpm -qa | grep gcc
gcc-4.8.5-36.el7_6.1.x86_64
gcc-c+±4.8.5-36.el7_6.1.x86_64
libgcc-4.8.5-36.el7_6.1.x86_64
gcc-gfortran-4.8.5-36.el7_6.1.x86_64


(Stéphane de Labrusse) #10

it should be good…did you use admin/admin ?

what is the output of systemctl status vboxweb-service vboxdrv

could you restart the server and check in /var/log/messages something bad relevant to virtualbox


(Jose Manuel Insausti) #11

[root@bi ~]# [root@bi ~]# systemctl status vboxweb-service vboxdrv -l
● vboxweb-service.service
Loaded: loaded (/usr/lib/virtualbox/vboxweb-service.sh; enabled; vendor preset: disabled)
Active: active (exited) since mar 2019-04-09 13:23:32 CEST; 3min 25s ago

abr 09 13:23:32 bi.xxxx.lan systemd[1]: Starting vboxweb-service.service…
abr 09 13:23:32 bi.xxxx.lan vboxweb-service.sh[16458]: vboxweb-service.sh: Starting VirtualBox web service.
abr 09 13:23:32 bi.xxxx.lan su[16464]: (to vboxweb) root on none
abr 09 13:23:32 bi.xxxx.lan systemd[1]: Started vboxweb-service.service.

● vboxdrv.service - VirtualBox Linux kernel module
Loaded: loaded (/usr/lib/virtualbox/vboxdrv.sh; enabled; vendor preset: disabled)
Active: active (exited) since mar 2019-04-09 13:17:03 CEST; 9min ago

abr 09 13:17:00 bi.xxxx.lan systemd[1]: Starting VirtualBox Linux kernel module…
abr 09 13:17:01 bi.xxxx.lan vboxdrv.sh[3893]: vboxdrv.sh: Starting VirtualBox services.
abr 09 13:17:03 bi.xxxx.lan systemd[1]: Started VirtualBox Linux kernel module.


(Stéphane de Labrusse) #12

nothing relevant…I cannot reproduce, do you have something in log, either when you start the service manually, or at the server start ?


(Jose Manuel Insausti) #13

what is the correct way to remove the phpvirtualbox from system completely and start over


(Jose Manuel Insausti) #14

I have seen the following.

in the phpvirtualbox config.php file the following username and password appear

vbox / pass

I have modified the username and password with the user and paswword admin of the domain administrator.

Now it works correctly but I do not like the solution.


(Stéphane de Labrusse) #15

are you talking of that in /etc/phpvirtualbox/config.php

class phpVBoxConfig {

/* Username / Password for system user that runs VirtualBox */
var $username = 'vboxweb';
var $password = '7mtA4Q_YGBwHKeH_';

/* SOAP URL of vboxwebsrv (not phpVirtualBox's URL) */
var $location = 'http://127.0.0.1:18083/';

/* Default language. See languages folder for more language options.
 * Can also be changed in File -> Preferences -> Language in
 * phpVirtualBox.
 */
var $language = 'en';


/* Set the standard VRDE Port Number / Range, e.g. 1010-1020 or 1027 */
var $vrdeports = '19000-19100';

/* Set the default VRDE address, e.g. 192.168.1.1 */
var $vrdeaddress = '192.168.56.13';

you can find the secret password at

cat /var/lib/nethserver/secrets/virtualbox

maybe you have a character that vbox doesn’t like ?


(Stéphane de Labrusse) #16

what is the output of

id vboxweb

we have an action at https://github.com/NethServer/nethserver-virtualbox/blob/master/VirtualBox/etc/e-smith/events/actions/nethserver-virtualbox-create-user-vboxweb to create the user


(Jose Manuel Insausti) #17

[root@bi phpvirtualbox]# id vboxweb
uid=1000(vboxweb) gid=1000(vboxweb) grupos=1000(vboxweb),963(vboxusers)


(Stéphane de Labrusse) #18

So when you try to use that user vboxweb in the configuration of phpvirtualbox, it fails, is that true ?

could you test to change the password

passwd vboxweb

then set a password and put it in the configuration file.


(Stéphane de Labrusse) #19

what about the secret key, something odd inside ?


(Jose Manuel Insausti) #20

I changed the password of the vboxweb user with

passwd vboxweb

I copied the password in
/etc/phpvirtualbox/config.php

var username = 'vboxweb'; var password = ‘NewPassword’;

Works correctly.


(Stéphane de Labrusse) #21

Could you send me by private message the password written in the secret folder please