PHPMyAdmin Upload Size Limit (PHP Upload Size Limit)

NethServer Version: 8
Module: Mariadb

Ok, I’m probably just developmentally challenged, however… I would like to restore a database backup from my current webserver, but the php upload limit is defaulted to 2048kb. Is this changeable, if so, how?

Hello @Solomon_Bachman welcome to the Nethserver community, We hope to provide you more value.

You mentioned restoring mysql database, then mentioned php upload limit.

Might i ask, what method were you using to restore the said database? is this through phpMyadmin or is it through the app you are hosting

1 Like

You can change the php settings in the webserver virtual host advanced settings:

Attempting to upload a sql dump through phpMyadmin.

I’ll take a look, I didn’t realize there was a virtual host for the phpMyadmin that is part of the mariadb module.

1 Like

Sorry, there’s no virtual host for phpmyadmin, I thought you wanted to use some webapp on the webserver…


@Solomon_Bachman I was able to set a 20M upload size with following steps on CLI:

Enter the pod:

runagent -m mariadb1

Add UPLOAD_LIMIT size in K, M or G to the environment file:

echo UPLOAD_LIMIT=20M >> environment

Restart the phpmyadmin-app:

systemctl --user restart phpmyadmin-app

You may remove the “UPLOAD_LIMIT=20M” line from the environment file and restart the service after uploading your database file.

1 Like

@mrmarkuz i presume those configs for webserver would not affect the PhpMyAdmin, which in this case seems to be the one with the limitations right?

1 Like

I’ll give this a go, thank you!

1 Like

It wont be enough the environment var must be mounted in the systemd service or the file environment itself can be mounted globally to the container

I was wrong I tought how to mount custom php in the environment file

You are true @mrmarkuz

1 Like

It was luck, I didn’t check the systemd file.
But it’s just a workaround. I think we need a higher upload limit default or maybe a UI control to raise it?

1 Like

Yep. The good new is there was a move of some module to nethforge. Mariadd is one of them.



new version coming

1 Like


wonderful works @stephdl you are a life saver.

Also make considerations for max execution time limit, some SQL files are huge, and therefore, their execurition time is longer.

I am not sure if this is in relation to PhpMadmin or if its something from the mariaDB side of things.

I encountered said issue importing a 400 Mb database, i reverted to cpanel based hosting…


If set, this option will override the maximum execution time in seconds for phpMyAdmin :config:option:`$cfg['ExecTimeLimit']` and PHP's `max_execution_time`.

.. note:: Format as `[0-9+]`. Default value is `600`.

10 minutes to upload 256MB, well it is true I live in europe with a 300Mb fiber internet connexion but but