phpLDAPadmin HowTo

SO first enable REPO EPEL

sudo rpm -Uvh epel-release-6*.rpm
yum install yum-utils
Disabling REPO for futher updates : 
yum-config-manager --disable epel

    # yum --enablerepo=epel -y install phpldapadmin

    # vi /etc/phpldapadmin/config.php

# line 397: uncomment, line 398: comment out
// $servers->setValue('login','attr','uid');

    # vi /etc/httpd/conf.d/phpldapadmin.conf

Alias /phpldapadmin /usr/share/phpldapadmin/htdocs
Alias /ldapadmin /usr/share/phpldapadmin/htdocs

  Order Deny,Allow
  Deny from all
  Allow from     # add access permission
  Allow from ::1

    # service httpd restart

    # http://(server's hostname or IP address)/ldapadmin/  
login : cn=libuser,dc=directory,dc=nh 
password : cat /var/lib/nethserver/secrets/libuser

cudos :smile: this works like a treat.
BTW, is it save to upgrade packages from epel repo, or does it break anything on ns side?

U could disable repo as well ! and if u need some packeges from it use yum --enablerepo=epel -y install

wow great. tnx @Nas
Maybe as seen in older posts, for the epel repo is better to disable it in the howto
so noone (like me) can forget it enabled

eorepo centos-base centos-updates nethserver-base nethserver-updates

what do you think?

1 Like

ok howto works, of course i’ve move all the conversation… @alefattorini can you fix it ? :stuck_out_tongue:

5 posts were split to a new topic: Proxy with authenticated group of user from external Openldap

I try following the step on Nethserver 7, it cans not login for cn=libuser,dc=directory,dc=nh
but when use Anonymous, can log in.
the Nethserver 7 is not allow to libuser login ?

Thank you

Don’t use libuser! We are working on LDAP ACLs, on rc3 you should use admin credentials. On rc2 you’d better wait

Good news are @stephdl is working on a RPM for phpLDAPadmin!

1 Like

Thank you, when the rc3 will be release.

We have to close some issues before the release

Thanks for the reminder :slight_smile:

1 Like

Tried to install phpldapadmin but when I use the url http://myserverip/ldapadmin/ I get:


Are you on your lan, default is restricted to the local network, did you use the default admin user ?

Yes I am.

No, because I get the error immediately bevor credetials are asked…

Ldap or samba ad ?

This Nethserver is a member of a MS AD.

Not tested this case, normally it just should work.

OK, any idea what I could do?

Check httpd/messages/secure log to understand what it occurs

cat /var/log/httpd/error_log

[Thu Mar 12 10:01:59.664762 2020] [authz_core:error] [pid 26079] [client] AH01630: client denied by server configuration: /usr/share/phpldapadmin/htdocs