Php update to 7.X?

freepbx
php

(Sebastian Gödecke) #1

NethServer Version: NethServer release 7.5.1804
Hi, FreePBX is running with errors when updateing. It seems to be a php-error. however php is in version 5.4 on my server. How could i use a updated version like 7.x to run freepbx without errors?

regards simpsonetti


(Dan) #2

https://wiki.nethserver.org/doku.php?id=php-scl


(Sebastian Gödecke) #3

Thats it, thanks.


(Stefano Fancello) #4

FreePBX already run using 5.6 from SCL.
What is the error? Where is it?
also take a look at this FreePBX - there was an error - just minutes after fresh install


(Stéphane de Labrusse) #5

Sure I cannot understand how my module could solve your issue, we just run a different version of php for apache vhostsand for /var/www/html


(Sebastian Gödecke) #6

Well, your module brings php >5.4 on nethserver7. So this helps me to run freepbx without errors in coremodul from freepbx.
Maybe there are other ways to solve this problem, i take this one.
Thanks.