PHP issue because deinstallation


NethServer release 7.6.1810 your_version
PHP your_module
Terrible Problem
Running several Wordpress installations on my nethserver.
I run an yum autoremove which removed all php installations expept 5.x
Wordpress need 6.x something.
I remember that i could choose the php version for each vhost, but that option is gone…
Tried to install php-shl with this instruction:
But when issuing:
yum install nethserver-php-scl --enablerepo=stephdl
i get many dependensy problems

       Requires: php70-php-mcrypt

Error: Package: nethserver-php-scl-1.2.7-1.ns7.sdl.x86_64 (stephdl)
Requires: php71-php-opcache
Error: Package: nethserver-php-scl-1.2.7-1.ns7.sdl.x86_64 (stephdl)
Requires: php72-php-bcmath
Error: Package: nethserver-php-scl-1.2.7-1.ns7.sdl.x86_64 (stephdl)
Requires: php71-php-soap
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

whats wrong?
Tried the installation several times no success.
I managed to install rh-php70, but i don’t know how to tell my vhosts to use it…
It’s kind of urgend, because my important websites are down…

OK, solved it. My repos where mixed up. had to delete the remi repo and reinstall it. now it is working again.
Still: why can’t nethserver use a modern PHP version, I don’t understand why centos is not doing that. Can’t work with an depricated software…
Happy for your work Stephan and Remi…
Merci Beaucoup

Probably because you need last version of PHP, but others might need older version, like this everybody is happy …or not :smiley:

Because CentOS stays with the same major/minor versions of all installed software (or, at least, all major installed software) throughout its release cycle for the sake of compatibility–code that runs on PHP 7.1, for example, doesn’t necessarily run on PHP 7.2.