Phones silent after Asterisk 18 update


I have updated Asterisk to 18 witch some fears… but it’s official, it should be ok after 1 day…

The problem is:
Calls are established, but:
For inbound calls there is no audio in any direction.
For outbound calls the voice comes in but no voice outbound.

Looks like an RTP issue?

It was working fine today until the update.

I have restarted both asterisk and nethserver, but no luck yet.
Also tried to re-apply some truck settings.

And tried to lower the RTP port range in Asterisk SIP settings from 16000-22000 to 16000-20000 (just to avoid the need to change firewall rules), but no luck yet (or is it for the internal phones only?).

It is a pjsip trunk, SIP Server Port: 5060

asterisk service:
green red TCP: 5060, 5061, 5038, 8088, 8089 UDP: 4569, 5036, 5060, 5160, 16000:22000

The ports are forwarded on a pfsense router NAT forward and firewall rules:
…edited out…

I am lost a bit about how to solve this problem, and it should be solved until tomorrow morning… :zipper_mouth_face:

Is there an option to roll back to the previous (12? 16?) version of asterisk?

Thank you for your help in advance!

Hi @CptCharlesG,
rolling back is not tested and really tricky, I don’t think that it’s an option.

  • Since you are using SIP without TLS, you can debug it with sngrep. You should see where the RTP traffic is sent.
  • This problem could be related to sip network settings, and the update only triggered it, verify your sip and nat settings from freepbx
  • check asterisk -r console if you have any error
  • check the trunk codec, if you use open g729 you have to download the Asterisk 18 version and restart asterisk
    wget -O /usr/lib64/asterisk/modules/


Thanks for the advises!

I have just went back to the office, it looks like all the physical phones are working.
The error occurred only with 3CX Phoe via VPN…

I will try to find out what is the problem here, but this is less important.

Alright, it was the Asterisk SIP Settings → NAT Settings → Local Networks… the VPN IP range was missing…

I wonder how it worked for a year, while I always tested the new FreePBX updates this way. :roll_eyes:
Possibly this setting had no effect previously?

Anyhow, it is solved now. :sunglasses: