PBX no connect to Webconfig PBX


I am using Neth-freepbx ( nethver 7.6 with all patsches stabel). I am config the Nethserver and FreePbx remoutely. So i am adding a secound network to FreePBX Web Acess.
After some restarts, configs an movinge the Neth-VM to a nother Host. I can not connect and Acess the FreePBX config Web. Nethterver Web config is okay …

I am erasing that extra Network and added it again, there was not netzmask in the Nethserver PBX Acess side

any Idea ?

It looks like had 2 do with moving the Nethserver from one XCP-NG server to the next one

hmm, more details are needed…


I using XCP-NG 7.6 (based on Cytrix Xenserver 7.6) as virtulisation platfrom with now two small xeon low power servern.

I move the nethserver VM from Server one to the next one. I had acess to the Nethserver 7.6 Webconfig, SSH an PBX ist running.

What kind of information will be helpfull ?

FreePBX is running 2, phone are ringing, but no acess 2 the FreePBX Webconfig. Browser Firefox and Chrome says no connect 2 Server, from the same Netzwork and remoutly.

Is the httpd fpbx service running?

systemctl status httpd-fpbx -l

Are there errors in the logfiles /var/log/httpd/* or /var/log/httpd-fpbx/* ?

[root@neth ~]#  systemctl status httpd-fpbx -l
● httpd-fpbx.service - The Apache HTTP Server instance for FreePBX
   Loaded: loaded (/usr/lib/systemd/system/httpd-fpbx.service; enabled; vendor preset: disabled)
   Active: active (running) since Sun 2019-01-06 16:23:48 CET; 7h ago
     Docs: man:httpd(8)
 Main PID: 4475 (httpd)
   Status: "Total requests: 0; Current requests/sec: 0; Current traffic:   0 B/sec"
   CGroup: /system.slice/httpd-fpbx.service
           ├─4475 /usr/sbin/httpd -f /etc/httpd/fpbx-conf/httpd.conf -DFOREGROUND
           ├─5078 /usr/sbin/httpd -f /etc/httpd/fpbx-conf/httpd.conf -DFOREGROUND
           ├─5079 /usr/sbin/httpd -f /etc/httpd/fpbx-conf/httpd.conf -DFOREGROUND
           ├─5081 /usr/sbin/httpd -f /etc/httpd/fpbx-conf/httpd.conf -DFOREGROUND
           ├─5084 /usr/sbin/httpd -f /etc/httpd/fpbx-conf/httpd.conf -DFOREGROUND
           └─5086 /usr/sbin/httpd -f /etc/httpd/fpbx-conf/httpd.conf -DFOREGROUND

Jan 06 16:23:43 neth.me.e~sion.de systemd[1]: Starting The Apache HTTP Server instance for FreePBX...
Jan 06 16:23:48 neth.me.e~sion.de systemd[1]: Started The Apache HTTP Server instance for FreePBX.

Looks like running ?

now looking into the log …
nothing new latest 16:32


[Sun Jan 06 16:15:58.017330 2019] [mpm_prefork:notice] [pid 4463] AH00170: caught SIGWINCH, shutting down gracefully 
[Sun Jan 06 16:23:46.611863 2019] [suexec:notice] [pid 4475] AH01232: suEXEC mechanism enabled (wrapper: /usr/sbin/suexec) 
[Sun Jan 06 16:23:46.722299 2019] [auth_digest:notice] [pid 4475] AH01757: generating secret for digest authentication ... 
[Sun Jan 06 16:23:46.723129 2019] [lbmethod_heartbeat:notice] [pid 4475] AH02282: No slotmem from mod_heartmonitor 
[Sun Jan 06 16:23:46.723228 2019] [ssl:warn] [pid 4475] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache] 
[Sun Jan 06 16:23:48.167552 2019] [mpm_prefork:notice] [pid 4475] AH00163: Apache/2.4.6 (CentOS) OpenSSL/1.0.2k-fips PHP/5.4.16 configured -- resuming normal operations 
[Sun Jan 06 16:23:48.167592 2019] [core:notice] [pid 4475] AH00094: Command line: '/usr/sbin/httpd -f /etc/httpd/fpbx-conf/httpd.conf -D FOREGROUND'

Does the config file /etc/httpd/conf.d/freepbx.conf reflect your network(s)?

<Location /freepbx>
    Deny from all
    Allow from

Firewall access is allowed?

config show httpd-fpbx

not nice :frowning:


can I edit them by hand ?
That looking confused …

Yes, via web UI or just execute:

config setprop httpd-fpbx ValidFrom
signal-event nethserver-freepbx-httpd-save

Now i know what going wrong …
not the way but what wrong.

when i move the VM and restart them ( i am not shure MAC daress was changed) the networks was kompletly killed
The is remoute and i reinstall it later, it looks like the error whe you dont add the remoute network in freepbx acess.

so my problem is solved, but will be nice to fix the bugs :wink:

There is a small bug in freePBX Acess when i am adding some network netmask is emty. After reload the side netmask ist there …

after adding remoute acess


I am try with a second Nethserver with pbx

[root@MEINE ~]# config show httpd-fpbx

but now it is working again :slight_smile:

THX 4 helping …

look like 2 bug …

  • after adding a new network missing the netmask, but it there. Reload the side the it is on the side.
  • and killing the netzwork settings whe somebody moves the VM. I will try it again next nigth and looking about the MAC-adress