P3scan error on NS 7

Hi @davidep,

What do you think about the pop3 scan error?

I have about 500 emails in the root email account (now forwarded to the administrator account) and growing!

TIA,
Gabriel

UPDATE:

  • If POP3 proxy is “Disabled”, I can receive emails with Thunderbird; no errors in “messages”.

  • If POP3 is “Enabled”, no matter which settings are chosen (Enabled or Disabled Antivirus and/or Antispam, Enabled or Disabled “POP3s scan (port 995)”, I can’t receive emails with Thunderbird; known errors from above in “messages”.

2 Likes

Thanks @GG_jr, it looks like p3scan has troubles with directory permissions.

@giacomo, @filippo_carletti do you have any idea?

2 Likes

I’ve found the problem: p3san needs the amavis user.

Execute this command: rpm -V p3scan
You should have the following output:

…UG… /var/run/p3scan
…UG… /var/spool/p3scan
…UG… /var/spool/p3scan/children
…UG… /var/spool/p3scan/notify

Then, install p3scan from testing:

yum --enablerepo=nethserver-testing update p3scan

Re-execute the above command, you shouldn’t have any output.
Try to receive new mails :wink:

Edit: adedd pull request

3 Likes

Hi @giacomo ,

It works as you said, with commands and the update, but there are still errors:

  • with “Antivirus” enabled in POP3 Proxy, cannot receive emails.

1 Like

I’ve never seen it before.
I hope @filippo_carletti has some clue.

p3scan uses clamdscan to check the file and parses the output.
Try to mimic the steps with:
/usr/bin/clamdscan --no-summary /var/spool/p3scan/children/SOMEFILE (I hope you’ll find leftovers there, otherwise copy a file there and chown it to amavis)

Hi @filippo_carletti ,

Sorry for my late answer, but I was in “business trip” for two days.

Sincerely, I don’t know how to use this command (if SOMEFILE must be replaced with the file that I find in /var/spool/p3scan/children/), so I try both “versions”.

After I did what @giacomo said, there is a file in /var/spool/p3scan/children/: 6503.

Please see the attached pictures to see what contains the 6503 file and what I obtained after I have run your command.

In this moment, POP3 proxy is enabled but with Antivirus disabled.

Kind regards,
Gabriel

Thank you @GG_jr, I think that the error about parsing clamd.conf is enough to reproduce the problem. I’ll keep you updated.

1 Like

TIA!

I made a mistake, 6503 is a “folder” not a “file”. :blush:
Sorry! :pensive:

@GG_jr, could you try to apply this fix?

2 Likes

Hi @filippo_carletti ,

I made the changes and it works!

No errors, with POP3 proxy “All enabled”.

Thank you!

PS

Can I mark this topic as solved now, or will wait the update ?

I’d wait for seeing this issue closed

1 Like

Done!
Rpms will be soon pushed to mirrors.

2 Likes

Already in Software center -> Updates!

Thank you @dev_team !

Gabriel

PS
@giacomo : Can you mark the topic as “solved” , please?

1 Like