Owncloud installation failed


#1

Hi to all !

I try to install owncloud via the software-center. Unfortunately the installation fails with die following error-message:

Task completed with errors S95nethserver-owncloud-conf-ldap #14 (exit status 256)
Template /var/www/html/owncloud/apps/user_ldap/appinfo/register_command.php #15 (exit status 1)expansion of /var/www/html/owncloud/apps/user_ldap/appinfo/register_command.php failed

I use:
System version: NethServer release 6.7 (final)
Kernel release : 2.6.32-573.12.1.el6.x86_64

Please tell me, what is to do to solve that problem.

Thank you in advance and best Greetings from Germany !

Telekomiker


(Artem Fedai) #2

Hi, have you installed Nethserver-Directory module first?


(Alessio Fattorini) #3

It should be a dependency of nethserver-owncloud
Something about the first configuration was broken. Probably remove and reinstall everything is a quick solution: db, directory and packages


#4

Hi,

thank you for the fast replays. I deinstalled the most services except

Base , Development tools, DNS and DHCP server, E-mail Server, MSQL server, Networking tools, System administration tools, Web server, Roundcube

Than I tried again to install nethserver-owncloud and got another error message:

Task completed with errors S95nethserver-owncloud-conf-ldap #14 (exit status 256)
Template /var/www/html/owncloud/apps/user_ldap/appinfo/register_command.php #15 (exit status 1)
expansion of /var/www/html/owncloud/apps/user_ldap/appinfo/register_command.php failed

Please let my explain, that I use DNS and DHCP on my firewall (IFfire), so I did not configure nethservers’s DNS- and DHCP-Services.

Is there any chance to solve that problem ? If not, how can I backup the configuration and use it after a new installation ?

Wishing a happy weekende …

Best regards from Telekomiker !


(Artem Fedai) #5

Hi run please the following commands:

diff -u  /etc/e-smith/templates/var/www/html/owncloud/apps/user_ldap/appinfo/register_command.php/register_command.php /var/www/html/owncloud/apps/user_ldap/appinfo/register_command.php

service slapd status

#6

Hi Artem,

Message after the diff-command:

diff: /var/www/html/owncloud/apps/user_ldap/appinfo/register_command.php: No such file or directory

Status message of slapd status:

slapd is stopped

And now ?

Thank you for the fast answer …

Best regards

Telekomiker


(Artem Fedai) #7

Run couple of times, till you see no process to kill :

killall slapd 

ater it

service slapd restart

Than try to reinstall OwnCloud


#8

Hi Artem,

[root@wizard ~]# killall slapd
[root@wizard ~]# killall slapd
[root@wizard ~]# killall slapd
slapd: no process killed

[root@wizard ~]# service slapd restart
Stopping slapd: [ OK ]
Starting slapd: [FAILED]

and now ?

Best thanks in advance …

Telekomiker


(Artem Fedai) #9

Lets arrange teamviewer session, i need to catch log files


(Alessio Fattorini) #10

Slapd is handled by upstart so you should use;
start slapd


(Artem Fedai) #11

it is on NS 7 :slight_smile: but there is still backward compatibility with service (sysinit)


(Artem Fedai) #12

@telekomiker have you solved the issue ?


#13

Hi Artem,

I was some days busy on my job, sorry.

Unfortunately the problem is any longer. In addition I started the recommended update (couse glibc and so on) and I got many errot messages:

Task completed with errors
S91nethserver-directory-init-admin #89 (exit status 28416)
S97nethserver-mail-update-admin #92 (exit status 28416)
S97nethserver-samba-sam-conf #93 (exit status 256)
S04user-create-unix #127 (exit status 28416)
S20nethserver-directory-organization-modify #129 (exit status 28416)
S25nethserver-directory-user-modify #132 (exit status 256)
S30nethserver-mail-account-update #134 (exit status 28416)
S04group-create-unix #143 (exit status 256)
S20group-modify-unix #146 (exit status 28416)
S30nethserver-mail-account-update #147 (exit status 28416)

so that I don’t restart the installation owncloud after that.

Your offer to look for yourself via a teamviewer session is heavily welcome