OpenVPN Routing Problems


i have already setup my OpenVPN Server. I´m able to connect to my Network with my iPhone. The problem is that i can´t reach the clients in the LAN.
The only local IP i can ping is my NS. What i have to configure that i can reach all the internal clients through the VPN ?

You can show the advanced settings @prostream ?

You should have some of those options

My OpenVPN configuration is exactly as above and I don’t have either of the “Advanced” options selected. I can connect using applications like Reflection to clients inside my network without any problems from my iPhone once OpenVPN is connected.
I don’t have anything on my phone to try ping, but could it just be as simple as ping being blocked. I’ve never liked ping as a test of network connectivity because too many things can block it.
Have you tried to connect to those clients with an application,

I have activated both of the advanced options. Even if i deactivate both of them i can´t reach my local IP Cams. I can really ping them from my local network so i think i also should be able to ping them through my VPN.

But i also can´t reach them via port 80. So i´m still not able to connect to clients in my LAN through my VPN. Anyone idea?

Okay this is solved. The reason why i couldn’t reach my cameras was that in the network config of the cameras was entered an old gateway.

1 Like

All right. As I tell my clients that have IT staff, make local tests until the system in this case NethServer. check each device and its settings sometimes a mask different network or network segment that is not the right leads us to think that it is NethServer.

So we know where is the problem. these things tend to happen when we move to a configuration and services and forget old change.

1 Like