OpenVPN RoadWarrior: drop down of AD users not populating

NethServer 7.9.2009

Hi All,

Struggling with a new issue in Nethserver. Have a working OpenVPN road-warrior with a pile of users authenticating against a Windows server domain.

Today we go to add a new user to the VPN, but the drop down of available users is not populating. Choose “System User” from the Mode, and the user drop down doesn’t populate.

When checking the System “Users and Groups” all the AD users are there.

How do we get the users in the drop-down in order to add them to the VPN? This has been done 100 or more times thus far without issue. What changed? How do we proceed to add users?

Is there anything in openvpn logs?


@primerpop cross check the user membership to groups in your AD.

Thanks, but I feel this is not an OpenVPN problem as the RoadWarrior side of this works just fine, it’s an issue where NethServer cannot enumerate the AD users in order to add them to the VPN.


The drop down of “User” is empty. Sometimes. Refreshing may or may not solve the problem.

Check for errors on the browser console.
Which browser?
How many users are on the AD?
Does it happen with other browsers too?

Nothing special in the console, Chrome/Edge, AD has 42 users.

Anyone an idea?

Tried but couldn’t reproduce the problem.

I tried too and it works for me, perhaps there is a command to request the users, like this field does.

Do you have an idea, how to find out, where the problem does come from

I have a behaviour like this too, there is nothing shown while I open Add acount, select System user and choose one.

You could try to execute /usr/libexec/nethserver/list-users which reads the LDAP tree.

1 Like